blob: 87fabecda0bef46e1614c8faa8da28681a3153c9 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "GNOME XSLT library"
2HOMEPAGE = "http://xmlsoft.org/XSLT/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
7
8SECTION = "libs"
9DEPENDS = "libxml2"
10
11SRC_URI = "ftp://xmlsoft.org/libxslt//libxslt-${PV}.tar.gz \
12 file://pkgconfig_fix.patch \
Patrick Williamsf1e5d692016-03-30 15:21:19 -050013 file://pkgconfig.patch \
14 file://CVE-2015-7995.patch"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050015
16SRC_URI[md5sum] = "9667bf6f9310b957254fdcf6596600b7"
17SRC_URI[sha256sum] = "5fc7151a57b89c03d7b825df5a0fae0a8d5f05674c0e7cf2937ecec4d54a028c"
18S = "${WORKDIR}/libxslt-${PV}"
19
20BINCONFIG = "${bindir}/xslt-config"
21
22inherit autotools pkgconfig binconfig-disabled lib_package
23
24# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
25do_configure_prepend () {
26 sed -i -e 's/ansidecl.h//' ${S}/configure.in
27
28 # The timestamps in the 1.1.28 tarball are messed up causing this file to
29 # appear out of date. Touch it so that we don't try to regenerate it.
30 touch ${S}/doc/xsltproc.1
31}
32
33EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
34# older versions of this recipe had ${PN}-utils
35RPROVIDES_${PN}-bin += "${PN}-utils"
36RCONFLICTS_${PN}-bin += "${PN}-utils"
37RREPLACES_${PN}-bin += "${PN}-utils"
38
39
40do_install_append_class-native () {
41 create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog.xml
42}
43
44FILES_${PN} += "${libdir}/libxslt-plugins"
45FILES_${PN}-dev += "${libdir}/xsltConf.sh"
46
47BBCLASSEXTEND = "native nativesdk"