Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Collection of simple PIN or passphrase entry dialogs" |
| 2 | DESCRIPTION = "\ |
| 3 | Pinentry is a collection of simple PIN or passphrase entry dialogs which \ |
| 4 | utilize the Assuan protocol as described by the aegypten project; see \ |
| 5 | http://www.gnupg.org/aegypten/ for details." |
| 6 | |
| 7 | HOMEPAGE = "http://www.gnupg.org/related_software/pinentry/index.en.html" |
| 8 | LICENSE = "GPLv2" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=cbbd794e2a0a289b9dfcc9f513d1996e" |
| 10 | |
| 11 | inherit autotools |
| 12 | |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame^] | 13 | DEPENDS = "gettext-native" |
| 14 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 15 | SRC_URI = "ftp://ftp.gnupg.org/gcrypt/${BPN}/${BPN}-${PV}.tar.bz2" |
| 16 | |
| 17 | SRC_URI[md5sum] = "f51d454f921111b5156a2291cbf70278" |
| 18 | SRC_URI[sha256sum] = "fd8bc1592ceb22bb492b07cb29b1b140bb882c859e6503b974254c0a4b4134d1" |
| 19 | |
| 20 | EXTRA_OECONF = "--disable-rpath \ |
| 21 | --disable-dependency-tracking \ |
| 22 | " |
| 23 | |
| 24 | PACKAGECONFIG ??= "ncurses libcap" |
| 25 | |
| 26 | PACKAGECONFIG[ncurses] = "--enable-ncurses --with-ncurses-include-dir=${STAGING_INCDIR}, --disable-ncurses, ncurses" |
| 27 | PACKAGECONFIG[libcap] = "--with-libcap, --without-libcap, libcap" |
| 28 | PACKAGECONFIG[qt4] = "--enable-pinentry-qt4, --disable-pinentry-qt4, qt4-x11" |
| 29 | PACKAGECONFIG[qt4_clipboard] = "--enable-pinentry-qt4-clipboard --enable-pinentry-qt4, --disable-pinentry-qt4-clipboard, qt4-x11" |
| 30 | PACKAGECONFIG[gtk2] = "--enable-pinentry-gtk2, --disable-pinentry-gtk2, gtk+ glib-2.0" |
| 31 | |
| 32 | #To use libsecret, add meta-gnome |
| 33 | PACKAGECONFIG[secret] = "--enable-libsecret, --disable-libsecret, libsecret" |