Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Filesystem and hardware benchmark and stress tool" |
| 2 | DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \ |
| 3 | stress/hardware verification. It has support for a number of I/O engines, \ |
| 4 | I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \ |
| 5 | and much more. It can work on block devices as well as files. fio accepts \ |
| 6 | job descriptions in a simple-to-understand text format. Several example job \ |
| 7 | files are included. fio displays all sorts of I/O performance information." |
| 8 | HOMEPAGE = "http://freecode.com/projects/fio" |
| 9 | SECTION = "console/tests" |
| 10 | LICENSE = "GPLv2" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 12 | |
Brad Bishop | 63ae878 | 2019-10-09 09:56:13 -0400 | [diff] [blame] | 13 | DEPENDS = "libaio zlib coreutils-native" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | DEPENDS += "${@bb.utils.contains('MACHINE_FEATURES', 'pmem', 'pmdk', '', d)}" |
| 15 | RDEPENDS_${PN} = "python3-core bash" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 16 | |
| 17 | PACKAGECONFIG_NUMA = "numa" |
| 18 | # ARM does not currently support NUMA |
| 19 | PACKAGECONFIG_NUMA_arm = "" |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 20 | PACKAGECONFIG_NUMA_armeb = "" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | |
| 22 | PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}" |
| 23 | PACKAGECONFIG[numa] = ",--disable-numa,numactl" |
| 24 | |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 25 | SRCREV = "267b164c372d57145880f365bab8d8a52bf8baa7" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 26 | SRC_URI = "git://git.kernel.dk/fio.git \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 27 | " |
| 28 | |
| 29 | S = "${WORKDIR}/git" |
| 30 | |
| 31 | # avoids build breaks when using no-static-libs.inc |
| 32 | DISABLE_STATIC = "" |
| 33 | |
| 34 | EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 35 | EXTRA_OECONF = "${@bb.utils.contains('MACHINE_FEATURES', 'x86', '--disable-optimizations', '', d)}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 36 | |
| 37 | do_configure() { |
| 38 | ./configure ${EXTRA_OECONF} |
| 39 | } |
| 40 | |
| 41 | do_install() { |
| 42 | oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir} |
| 43 | install -d ${D}/${docdir}/${PN} |
| 44 | cp -R --no-dereference --preserve=mode,links -v ${S}/examples ${D}/${docdir}/${PN}/ |
| 45 | } |