Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | DESCRIPTION = "The Openobex project is an open source implementation of the \ |
| 2 | Object Exchange (OBEX) protocol." |
| 3 | HOMEPAGE = "http://openobex.triq.net" |
| 4 | SECTION = "libs" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 5 | LICENSE = "GPLv2 & LGPLv2.1" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \ |
| 7 | file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \ |
| 8 | " |
| 9 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 10 | DEPENDS = "virtual/libusb0" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 11 | DEPENDS_append_class-target = " bluez5" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 13 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}/${PV}/${BP}-Source.tar.gz \ |
| 14 | " |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 15 | SRC_URI[md5sum] = "f6e0b6cb7dcfd731460a7e9a91429a3a" |
| 16 | SRC_URI[sha256sum] = "158860aaea52f0fce0c8e4b64550daaae06df2689e05834697b7e8c7d73dd4fc" |
| 17 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 18 | S = "${WORKDIR}/${BP}-Source" |
| 19 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | inherit cmake pkgconfig |
| 21 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 22 | EXTRA_OECONF = " -DCMAKE_SKIP_RPATH=ON " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 23 | EXTRA_OECMAKE += "-DBUILD_DOCUMENTATION=OFF" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 24 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 25 | ASNEEDED = "" |
| 26 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 27 | do_install_append () { |
| 28 | rmdir ${D}${bindir} |
| 29 | } |
| 30 | |
| 31 | PACKAGES =+ "openobex-apps" |
| 32 | FILES_${PN}-apps = "${bindir}/*" |
| 33 | FILES_${PN} += "${libdir}/lib*.so.*" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 34 | FILES_${PN}-dev += "${bindir}/openobex-config" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 35 | DEBIAN_NOAUTONAME_${PN}-apps = "1" |
| 36 | |
| 37 | BBCLASSEXTEND = "native" |