Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "The tpm2-tss-engine project implements a cryptographic engine for OpenSSL." |
| 2 | DESCRIPTION = "The tpm2-tss-engine project implements a cryptographic engine for OpenSSL for Trusted Platform Module (TPM 2.0) using the tpm2-tss software stack that follows the Trusted Computing Groups (TCG) TPM Software Stack (TSS 2.0). It uses the Enhanced System API (ESAPI) interface of the TSS 2.0 for downwards communication. It supports RSA decryption and signatures as well as ECDSA signatures." |
| 3 | |
Andrew Geissler | 064f75b | 2020-06-27 00:14:46 -0500 | [diff] [blame] | 4 | LICENSE = "BSD-3-Clause" |
Andrew Geissler | 9d3cc05 | 2021-03-31 13:36:22 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7b3ab643b9ce041de515d1ed092a36d4" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 6 | |
| 7 | SECTION = "security/tpm" |
| 8 | |
| 9 | DEPENDS = "autoconf-archive-native bash-completion libtss2 libgcrypt openssl" |
| 10 | |
Andrew Geissler | 9d3cc05 | 2021-03-31 13:36:22 -0500 | [diff] [blame] | 11 | SRCREV = "6f387a4efe2049f1b4833e8f621c77231bc1eef4" |
| 12 | SRC_URI = "git://github.com/tpm2-software/tpm2-tss-engine.git;branch=v1.1.x" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | |
| 14 | inherit autotools-brokensep pkgconfig systemd |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | PACKAGES += "${PN}-engines ${PN}-engines-staticdev ${PN}-bash-completion" |
| 19 | |
| 20 | FILES_${PN}-dev = "${libdir}/engines-1.1/tpm2tss.so ${includedir}/*" |
| 21 | FILES_${PN}-engines = "${libdir}/engines-1.1/lib*.so*" |
| 22 | FILES_${PN}-engines-staticdev = "${libdir}/engines-1.1/libtpm2tss.a" |
| 23 | FILES_${PN}-bash-completion += "${datadir}/bash-completion/completions" |