blob: 3456383c3acaa85b504955fa17e75b32ff9ef920 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "GTK+2 standard themes"
2HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/gnome-themes-standard/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome"
5
Andrew Geissler9aee5002022-03-30 16:27:02 +00006LICENSE = "LGPL-2.1-only"
Brad Bishop90ca7472019-08-20 09:15:15 -04007LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
Brad Bishop26bdd442019-08-16 17:08:17 -04008
Patrick Williamsac13d5f2023-11-24 18:59:46 -06009GNOMEBASEBUILDCLASS = "autotools"
Patrick Williams03514f12024-04-05 07:04:11 -050010GTKIC_VERSION = '3'
Brad Bishop8410d612019-11-25 09:40:59 -050011inherit gnomebase gettext gtk-icon-cache upstream-version-is-even features_check
Brad Bishop26bdd442019-08-16 17:08:17 -040012
Patrick Williams03514f12024-04-05 07:04:11 -050013ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
Brad Bishop26bdd442019-08-16 17:08:17 -040014
Patrick Williams03514f12024-04-05 07:04:11 -050015DEPENDS += "intltool-native gtk+3 librsvg"
Brad Bishop26bdd442019-08-16 17:08:17 -040016
Andrew Geissler595f6302022-01-24 19:11:47 +000017# PV is 3.28 not 3.28.0, so the gnomebase SRC_URI isn't right.
18SRC_URI = "${GNOME_MIRROR}/${BPN}/${PV}/${BPN}-${PV}.tar.xz;name=archive"
Brad Bishop90ca7472019-08-20 09:15:15 -040019SRC_URI[archive.md5sum] = "f9f2c6c521948da427f702372e16f826"
20SRC_URI[archive.sha256sum] = "7c4ba0bff001f06d8983cfc105adaac42df1d1267a2591798a780bac557a5819"
Brad Bishop26bdd442019-08-16 17:08:17 -040021
Patrick Williams03514f12024-04-05 07:04:11 -050022EXTRA_OECONF = "--disable-gtk2-engine"
Brad Bishop26bdd442019-08-16 17:08:17 -040023
Patrick Williams213cb262021-08-07 19:21:33 -050024do_install:append() {
Brad Bishop26bdd442019-08-16 17:08:17 -040025 # Only building Adwaita, remove highcontrast files
Andrew Geissler5082cc72023-09-11 08:41:39 -040026 rm -rf ${D}${datadir}/themes/HighContrast \
27 ${D}${datadir}/icons
Brad Bishop26bdd442019-08-16 17:08:17 -040028
29 # The libtool archive file is unneeded with shared libs on modern Linux
30 rm -rf ${D}${libdir}/gtk-2.0/2.10.0/engines/libadwaita.la
31}
32
33# There could be gnome-theme-highcontrast as well but that requires
34# gtk+3 and includes lots of icons (is also broken with B != S).
35PACKAGES += "gnome-theme-adwaita \
36 gnome-theme-adwaita-dark \
37 "
38
Andrew Geissler5082cc72023-09-11 08:41:39 -040039FILES:gnome-theme-adwaita = "${datadir}/themes/Adwaita \
Brad Bishop26bdd442019-08-16 17:08:17 -040040 ${libdir}/gtk-2.0/2.10.0/engines/libadwaita.so"
41
Andrew Geissler5082cc72023-09-11 08:41:39 -040042FILES:gnome-theme-adwaita-dark = "${datadir}/themes/Adwaita-dark"
Patrick Williams213cb262021-08-07 19:21:33 -050043RDEPENDS:gnome-theme-adwaita-dark = "gnome-theme-adwaita"
Brad Bishop26bdd442019-08-16 17:08:17 -040044
45# gnome-themes-standard is empty and doesn't exist
Patrick Williams213cb262021-08-07 19:21:33 -050046RDEPENDS:${PN}-dev = ""