Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "open source telephony" |
| 2 | DESCRIPTION = "oFono is a stack for mobile telephony devices on Linux. oFono supports speaking to telephony devices through specific drivers, or with generic AT commands." |
| 3 | HOMEPAGE = "http://www.ofono.org" |
| 4 | BUGTRACKER = "https://01.org/jira/browse/OF" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 5 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \ |
| 7 | file://src/ofono.h;beginline=1;endline=20;md5=3ce17d5978ef3445def265b98899c2ee" |
| 8 | DEPENDS = "dbus glib-2.0 udev mobile-broadband-provider-info ell" |
| 9 | |
| 10 | SRC_URI = "\ |
| 11 | ${KERNELORG_MIRROR}/linux/network/${BPN}/${BP}.tar.xz \ |
| 12 | file://ofono \ |
| 13 | file://0001-mbim-add-an-optional-TEMP_FAILURE_RETRY-macro-copy.patch \ |
| 14 | file://0002-mbim-Fix-build-with-ell-0.39-by-restoring-unlikely-m.patch \ |
| 15 | " |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 16 | SRC_URI[sha256sum] = "93580adc1afd1890dc516efb069de0c5cdfef014415256ddfb28ab172df2d11d" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 17 | |
| 18 | inherit autotools pkgconfig update-rc.d systemd gobject-introspection-data |
| 19 | |
| 20 | INITSCRIPT_NAME = "ofono" |
| 21 | INITSCRIPT_PARAMS = "defaults 22" |
| 22 | SYSTEMD_SERVICE:${PN} = "ofono.service" |
| 23 | |
| 24 | PACKAGECONFIG ??= "\ |
| 25 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
| 26 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \ |
| 27 | " |
| 28 | PACKAGECONFIG[systemd] = "--with-systemdunitdir=${systemd_system_unitdir}/,--with-systemdunitdir=" |
| 29 | PACKAGECONFIG[bluez] = "--enable-bluetooth, --disable-bluetooth, bluez5" |
| 30 | |
| 31 | EXTRA_OECONF += "--enable-test --enable-external-ell" |
| 32 | |
| 33 | do_configure:prepend() { |
| 34 | bbnote "Removing bundled ell from ${S}/ell to prevent including it" |
| 35 | rm -rf ${S}/ell |
| 36 | } |
| 37 | |
| 38 | do_install:append() { |
| 39 | install -d ${D}${sysconfdir}/init.d/ |
| 40 | install -m 0755 ${WORKDIR}/ofono ${D}${sysconfdir}/init.d/ofono |
| 41 | } |
| 42 | |
| 43 | PACKAGES =+ "${PN}-tests" |
| 44 | |
| 45 | FILES:${PN} += "${systemd_unitdir}" |
| 46 | FILES:${PN}-tests = "${libdir}/${BPN}/test" |
| 47 | |
| 48 | RDEPENDS:${PN} += "dbus" |
| 49 | RDEPENDS:${PN}-tests = "\ |
| 50 | python3-core \ |
| 51 | python3-dbus \ |
| 52 | ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'python3-pygobject', '', d)} \ |
| 53 | " |
| 54 | |
| 55 | RRECOMMENDS:${PN} += "kernel-module-tun mobile-broadband-provider-info" |