Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Text shaping library" |
| 2 | DESCRIPTION = "HarfBuzz is an OpenType text shaping engine." |
| 3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz" |
| 4 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz" |
| 5 | SECTION = "libs" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=6ee0f16281694fb6aa689cca1e0fb3da \ |
| 8 | file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc \ |
| 9 | " |
| 10 | |
| 11 | UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases" |
| 12 | UPSTREAM_CHECK_REGEX = "harfbuzz-(?P<pver>\d+(\.\d+)+).tar" |
| 13 | |
| 14 | SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.xz" |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "c5bc33ac099b2e52f01d27cde21cee4281b9d5bfec7684135e268512478bc9ee" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 16 | |
| 17 | inherit meson pkgconfig lib_package gtk-doc gobject-introspection |
| 18 | |
| 19 | GIR_MESON_ENABLE_FLAG = 'enabled' |
| 20 | GIR_MESON_DISABLE_FLAG = 'disabled' |
| 21 | GTKDOC_MESON_ENABLE_FLAG = 'enabled' |
| 22 | GTKDOC_MESON_DISABLE_FLAG = 'disabled' |
| 23 | |
| 24 | PACKAGECONFIG ??= "cairo freetype glib icu" |
| 25 | PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo" |
| 26 | PACKAGECONFIG[freetype] = "-Dfreetype=enabled,-Dfreetype=disabled,freetype" |
| 27 | PACKAGECONFIG[glib] = "-Dglib=enabled,-Dglib=disabled,glib-2.0" |
| 28 | PACKAGECONFIG[graphite] = "-Dgraphite=enabled,-Dgraphite=disabled,graphite2" |
| 29 | PACKAGECONFIG[icu] = "-Dicu=enabled,-Dicu=disabled,icu" |
| 30 | |
| 31 | PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset" |
| 32 | |
| 33 | LEAD_SONAME = "libharfbuzz.so" |
| 34 | |
| 35 | do_install:append() { |
| 36 | # If no tools are installed due to PACKAGECONFIG then this directory is |
| 37 | #still installed, so remove it to stop packaging wanings. |
| 38 | rmdir --ignore-fail-on-non-empty ${D}${bindir} |
| 39 | } |
| 40 | |
| 41 | FILES:${PN}-icu = "${libdir}/libharfbuzz-icu.so.*" |
| 42 | FILES:${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \ |
| 43 | ${libdir}/libharfbuzz-icu.so \ |
| 44 | ${libdir}/pkgconfig/harfbuzz-icu.pc \ |
| 45 | " |
| 46 | FILES:${PN}-subset = "${libdir}/libharfbuzz-subset.so.*" |
| 47 | |
| 48 | BBCLASSEXTEND = "native nativesdk" |