Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Support for reading various archive formats" |
| 2 | DESCRIPTION = "C library and command-line tools for reading and writing tar, cpio, zip, ISO, and other archive formats" |
| 3 | HOMEPAGE = "http://www.libarchive.org/" |
| 4 | SECTION = "devel" |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame^] | 5 | LICENSE = "BSD-2-Clause" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=fe01f5e02b1f0cc934d593a7b0ddceb6" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | |
| 8 | DEPENDS = "e2fsprogs-native" |
| 9 | |
| 10 | PACKAGECONFIG ?= "zlib bz2 xz lzo" |
| 11 | |
| 12 | PACKAGECONFIG_append_class-target = "\ |
| 13 | libxml2 \ |
| 14 | ${@bb.utils.filter('DISTRO_FEATURES', 'acl xattr', d)} \ |
| 15 | " |
| 16 | |
| 17 | DEPENDS_BZIP2 = "bzip2-replacement-native" |
| 18 | DEPENDS_BZIP2_class-target = "bzip2" |
| 19 | |
| 20 | PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl," |
| 21 | PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr," |
| 22 | PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib," |
| 23 | PACKAGECONFIG[bz2] = "--with-bz2lib,--without-bz2lib,${DEPENDS_BZIP2}," |
| 24 | PACKAGECONFIG[xz] = "--with-lzma,--without-lzma,xz," |
| 25 | PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl," |
| 26 | PACKAGECONFIG[libxml2] = "--with-xml2,--without-xml2,libxml2," |
| 27 | PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat," |
| 28 | PACKAGECONFIG[lzo] = "--with-lzo2,--without-lzo2,lzo," |
| 29 | PACKAGECONFIG[nettle] = "--with-nettle,--without-nettle,nettle," |
| 30 | PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4," |
| 31 | |
| 32 | EXTRA_OECONF += "--enable-largefile" |
| 33 | |
| 34 | SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 35 | " |
| 36 | |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 37 | SRC_URI[md5sum] = "6046396255bd7cf6d0f6603a9bda39ac" |
| 38 | SRC_URI[sha256sum] = "8643d50ed40c759f5412a3af4e353cffbce4fdf3b5cf321cb72cacf06b2d825e" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 39 | |
| 40 | inherit autotools update-alternatives pkgconfig |
| 41 | |
| 42 | CPPFLAGS += "-I${WORKDIR}/extra-includes" |
| 43 | |
| 44 | do_configure[cleandirs] += "${WORKDIR}/extra-includes" |
| 45 | do_configure_prepend() { |
| 46 | # We just need the headers for some type constants, so no need to |
| 47 | # build all of e2fsprogs for the target |
| 48 | cp -R ${STAGING_INCDIR_NATIVE}/ext2fs ${WORKDIR}/extra-includes/ |
| 49 | } |
| 50 | |
| 51 | ALTERNATIVE_PRIORITY = "80" |
| 52 | |
| 53 | PACKAGES =+ "bsdtar" |
| 54 | FILES_bsdtar = "${bindir}/bsdtar" |
| 55 | |
| 56 | ALTERNATIVE_bsdtar = "tar" |
| 57 | ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar" |
| 58 | ALTERNATIVE_TARGET[tar] = "${bindir}/bsdtar" |
| 59 | |
| 60 | PACKAGES =+ "bsdcpio" |
| 61 | FILES_bsdcpio = "${bindir}/bsdcpio" |
| 62 | |
| 63 | ALTERNATIVE_bsdcpio = "cpio" |
| 64 | ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio" |
| 65 | ALTERNATIVE_TARGET[cpio] = "${bindir}/bsdcpio" |
| 66 | |
| 67 | BBCLASSEXTEND = "native nativesdk" |