Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame^] | 1 | SUMMARY = "RISC-V Open Source Supervisor Binary Interface (OpenSBI)" |
| 2 | DESCRIPTION = "OpenSBI aims to provide an open-source and extensible implementation of the RISC-V SBI specification for a platform specific firmware (M-mode) and a general purpose OS, hypervisor or bootloader (S-mode or HS-mode). OpenSBI implementation can be easily extended by RISC-V platform or System-on-Chip vendors to fit a particular hadware configuration." |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=c36118b4f615f9da37635f2a7ac8ccaf" |
| 5 | DEPENDS += "dtc-native" |
| 6 | |
| 7 | require opensbi-payloads.inc |
| 8 | |
| 9 | inherit autotools-brokensep |
| 10 | |
| 11 | SRCREV = "ca20ac0cd4c099006d4eea4d9ac7bd7b58e2ae0f" |
| 12 | SRC_URI = "git://github.com/riscv/opensbi.git \ |
| 13 | file://0001-Makefile-Don-t-specify-mabi-or-march.patch \ |
| 14 | file://0002-lib-Create-a-sbi_ipi_data-structure.patch \ |
| 15 | " |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | SRC_URI[md5sum] = "621f38d8205ef5fb185e4055025e73df" |
| 20 | SRC_URI[sha256sum] = "07f18b73abf3b85aabe5bead19a923716c100d30eb58033459f39c3a224be300" |
| 21 | |
| 22 | EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D}" |
| 23 | # If RISCV_SBI_PAYLOAD is set then include it as a payload |
| 24 | EXTRA_OEMAKE_append = " ${@riscv_get_extra_oemake_image(d)} ${@riscv_get_extra_oemake_fdt(d)}" |
| 25 | |
| 26 | # Required if specifying a custom payload |
| 27 | do_compile[depends] += "${@riscv_get_do_compile_depends(d)}" |
| 28 | |
| 29 | do_install_append() { |
| 30 | # In the future these might be required as a dependency for other packages. |
| 31 | # At the moment just delete them to avoid warnings |
| 32 | rm -r ${D}/include |
| 33 | rm -r ${D}/platform/${RISCV_SBI_PLAT}/lib |
| 34 | rm -r ${D}/platform/${RISCV_SBI_PLAT}/firmware/payloads |
| 35 | } |
| 36 | |
| 37 | do_deploy () { |
| 38 | install -d ${DEPLOY_DIR_IMAGE} |
| 39 | install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_payload.* ${DEPLOY_DIR_IMAGE}/ |
| 40 | install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_jump.* ${DEPLOY_DIR_IMAGE}/ |
| 41 | } |
| 42 | |
| 43 | addtask deploy after do_install |
| 44 | |
| 45 | FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_jump.*" |
| 46 | FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_payload.*" |
| 47 | |
| 48 | COMPATIBLE_HOST = "(riscv64|riscv32).*" |
| 49 | INHIBIT_PACKAGE_STRIP = "1" |