Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "A suite of security-related network utilities based on \ |
| 2 | the SSH protocol including the ssh client and sshd server" |
| 3 | DESCRIPTION = "Secure rlogin/rsh/rcp/telnet replacement (OpenSSH) \ |
| 4 | Ssh (Secure Shell) is a program for logging into a remote machine \ |
| 5 | and for executing commands on a remote machine." |
| 6 | HOMEPAGE = "http://www.openssh.com/" |
| 7 | SECTION = "console/network" |
| 8 | LICENSE = "BSD" |
| 9 | LIC_FILES_CHKSUM = "file://LICENCE;md5=429658c6612f3a9b1293782366ab29d8" |
| 10 | |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame^] | 11 | DEPENDS = "zlib openssl virtual/crypt" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 12 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" |
| 13 | |
| 14 | SRC_URI = "http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \ |
| 15 | file://sshd_config \ |
| 16 | file://ssh_config \ |
| 17 | file://init \ |
| 18 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \ |
| 19 | file://sshd.socket \ |
| 20 | file://sshd@.service \ |
| 21 | file://sshdgenkeys.service \ |
| 22 | file://volatiles.99_sshd \ |
| 23 | file://run-ptest \ |
| 24 | file://fix-potential-signed-overflow-in-pointer-arithmatic.patch \ |
| 25 | file://sshd_check_keys \ |
| 26 | file://add-test-support-for-busybox.patch \ |
| 27 | " |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 28 | SRC_URI[md5sum] = "bf050f002fe510e1daecd39044e1122d" |
| 29 | SRC_URI[sha256sum] = "bd943879e69498e8031eb6b7f44d08cdc37d59a7ab689aa0b437320c3481fd68" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 30 | |
| 31 | PAM_SRC_URI = "file://sshd" |
| 32 | |
| 33 | inherit useradd update-rc.d update-alternatives systemd |
| 34 | |
| 35 | USERADD_PACKAGES = "${PN}-sshd" |
| 36 | USERADD_PARAM_${PN}-sshd = "--system --no-create-home --home-dir /var/run/sshd --shell /bin/false --user-group sshd" |
| 37 | INITSCRIPT_PACKAGES = "${PN}-sshd" |
| 38 | INITSCRIPT_NAME_${PN}-sshd = "sshd" |
| 39 | INITSCRIPT_PARAMS_${PN}-sshd = "defaults 9" |
| 40 | |
| 41 | SYSTEMD_PACKAGES = "${PN}-sshd" |
| 42 | SYSTEMD_SERVICE_${PN}-sshd = "sshd.socket" |
| 43 | |
| 44 | inherit autotools-brokensep ptest |
| 45 | |
| 46 | EXTRA_AUTORECONF += "--exclude=aclocal" |
| 47 | |
| 48 | # login path is hardcoded in sshd |
| 49 | EXTRA_OECONF = "'LOGIN_PROGRAM=${base_bindir}/login' \ |
| 50 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)} \ |
| 51 | --without-zlib-version-check \ |
| 52 | --with-privsep-path=${localstatedir}/run/sshd \ |
| 53 | --sysconfdir=${sysconfdir}/ssh \ |
| 54 | --with-xauth=${bindir}/xauth \ |
| 55 | --disable-strip \ |
| 56 | " |
| 57 | |
| 58 | # musl doesn't implement wtmp/utmp |
| 59 | EXTRA_OECONF_append_libc-musl = " --disable-wtmp" |
| 60 | |
| 61 | # Since we do not depend on libbsd, we do not want configure to use it |
| 62 | # just because it finds libutil.h. But, specifying --disable-libutil |
| 63 | # causes compile errors, so... |
| 64 | CACHED_CONFIGUREVARS += "ac_cv_header_bsd_libutil_h=no ac_cv_header_libutil_h=no" |
| 65 | |
| 66 | # passwd path is hardcoded in sshd |
| 67 | CACHED_CONFIGUREVARS += "ac_cv_path_PATH_PASSWD_PROG=${bindir}/passwd" |
| 68 | |
| 69 | # We don't want to depend on libblockfile |
| 70 | CACHED_CONFIGUREVARS += "ac_cv_header_maillock_h=no" |
| 71 | |
| 72 | do_configure_prepend () { |
| 73 | export LD="${CC}" |
| 74 | install -m 0644 ${WORKDIR}/sshd_config ${B}/ |
| 75 | install -m 0644 ${WORKDIR}/ssh_config ${B}/ |
| 76 | } |
| 77 | |
| 78 | do_compile_ptest() { |
| 79 | # skip regress/unittests/ binaries: this will silently skip |
| 80 | # unittests in run-ptests which is good because they are so slow. |
| 81 | oe_runmake regress/modpipe regress/setuid-allowed regress/netcat \ |
| 82 | regress/check-perm regress/mkdtemp |
| 83 | } |
| 84 | |
| 85 | do_install_append () { |
| 86 | if [ "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" ]; then |
| 87 | install -D -m 0644 ${WORKDIR}/sshd ${D}${sysconfdir}/pam.d/sshd |
| 88 | sed -i -e 's:#UsePAM no:UsePAM yes:' ${D}${sysconfdir}/ssh/sshd_config |
| 89 | fi |
| 90 | |
| 91 | if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then |
| 92 | sed -i -e 's:#X11Forwarding no:X11Forwarding yes:' ${D}${sysconfdir}/ssh/sshd_config |
| 93 | fi |
| 94 | |
| 95 | install -d ${D}${sysconfdir}/init.d |
| 96 | install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/sshd |
| 97 | rm -f ${D}${bindir}/slogin ${D}${datadir}/Ssh.bin |
| 98 | rmdir ${D}${localstatedir}/run/sshd ${D}${localstatedir}/run ${D}${localstatedir} |
| 99 | install -d ${D}/${sysconfdir}/default/volatiles |
| 100 | install -m 644 ${WORKDIR}/volatiles.99_sshd ${D}/${sysconfdir}/default/volatiles/99_sshd |
| 101 | install -m 0755 ${S}/contrib/ssh-copy-id ${D}${bindir} |
| 102 | |
| 103 | # Create config files for read-only rootfs |
| 104 | install -d ${D}${sysconfdir}/ssh |
| 105 | install -m 644 ${D}${sysconfdir}/ssh/sshd_config ${D}${sysconfdir}/ssh/sshd_config_readonly |
| 106 | sed -i '/HostKey/d' ${D}${sysconfdir}/ssh/sshd_config_readonly |
| 107 | echo "HostKey /var/run/ssh/ssh_host_rsa_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly |
| 108 | echo "HostKey /var/run/ssh/ssh_host_ecdsa_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly |
| 109 | echo "HostKey /var/run/ssh/ssh_host_ed25519_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly |
| 110 | |
| 111 | install -d ${D}${systemd_unitdir}/system |
| 112 | install -c -m 0644 ${WORKDIR}/sshd.socket ${D}${systemd_unitdir}/system |
| 113 | install -c -m 0644 ${WORKDIR}/sshd@.service ${D}${systemd_unitdir}/system |
| 114 | install -c -m 0644 ${WORKDIR}/sshdgenkeys.service ${D}${systemd_unitdir}/system |
| 115 | sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \ |
| 116 | -e 's,@SBINDIR@,${sbindir},g' \ |
| 117 | -e 's,@BINDIR@,${bindir},g' \ |
| 118 | -e 's,@LIBEXECDIR@,${libexecdir}/${BPN},g' \ |
| 119 | ${D}${systemd_unitdir}/system/sshd.socket ${D}${systemd_unitdir}/system/*.service |
| 120 | |
| 121 | sed -i -e 's,@LIBEXECDIR@,${libexecdir}/${BPN},g' \ |
| 122 | ${D}${sysconfdir}/init.d/sshd |
| 123 | |
| 124 | install -D -m 0755 ${WORKDIR}/sshd_check_keys ${D}${libexecdir}/${BPN}/sshd_check_keys |
| 125 | } |
| 126 | |
| 127 | do_install_ptest () { |
| 128 | sed -i -e "s|^SFTPSERVER=.*|SFTPSERVER=${libexecdir}/sftp-server|" regress/test-exec.sh |
| 129 | cp -r regress ${D}${PTEST_PATH} |
| 130 | } |
| 131 | |
| 132 | ALLOW_EMPTY_${PN} = "1" |
| 133 | |
| 134 | PACKAGES =+ "${PN}-keygen ${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-sftp ${PN}-misc ${PN}-sftp-server" |
| 135 | FILES_${PN}-scp = "${bindir}/scp.${BPN}" |
| 136 | FILES_${PN}-ssh = "${bindir}/ssh.${BPN} ${sysconfdir}/ssh/ssh_config" |
| 137 | FILES_${PN}-sshd = "${sbindir}/sshd ${sysconfdir}/init.d/sshd ${systemd_unitdir}/system" |
| 138 | FILES_${PN}-sshd += "${sysconfdir}/ssh/moduli ${sysconfdir}/ssh/sshd_config ${sysconfdir}/ssh/sshd_config_readonly ${sysconfdir}/default/volatiles/99_sshd ${sysconfdir}/pam.d/sshd" |
| 139 | FILES_${PN}-sshd += "${libexecdir}/${BPN}/sshd_check_keys" |
| 140 | FILES_${PN}-sftp = "${bindir}/sftp" |
| 141 | FILES_${PN}-sftp-server = "${libexecdir}/sftp-server" |
| 142 | FILES_${PN}-misc = "${bindir}/ssh* ${libexecdir}/ssh*" |
| 143 | FILES_${PN}-keygen = "${bindir}/ssh-keygen" |
| 144 | |
| 145 | RDEPENDS_${PN} += "${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-keygen" |
| 146 | RDEPENDS_${PN}-sshd += "${PN}-keygen ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam-plugin-keyinit pam-plugin-loginuid', '', d)}" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 147 | RRECOMMENDS_${PN}-sshd_append_class-target = " rng-tools" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 148 | # gdb would make attach-ptrace test pass rather than skip but not worth the build dependencies |
| 149 | RDEPENDS_${PN}-ptest += "${PN}-sftp ${PN}-misc ${PN}-sftp-server make sed sudo coreutils" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 150 | |
| 151 | RPROVIDES_${PN}-ssh = "ssh" |
| 152 | RPROVIDES_${PN}-sshd = "sshd" |
| 153 | |
| 154 | RCONFLICTS_${PN} = "dropbear" |
| 155 | RCONFLICTS_${PN}-sshd = "dropbear" |
| 156 | |
| 157 | CONFFILES_${PN}-sshd = "${sysconfdir}/ssh/sshd_config" |
| 158 | CONFFILES_${PN}-ssh = "${sysconfdir}/ssh/ssh_config" |
| 159 | |
| 160 | ALTERNATIVE_PRIORITY = "90" |
| 161 | ALTERNATIVE_${PN}-scp = "scp" |
| 162 | ALTERNATIVE_${PN}-ssh = "ssh" |
| 163 | |
| 164 | BBCLASSEXTEND += "nativesdk" |