blob: 47b234e23522cd2587197db993c39c411541fdcb [file] [log] [blame]
Patrick Williams7784c422022-11-17 07:29:11 -06001SUMMARY = "GNOME Online Accounts - Single sign-on framework for GNOME"
2LICENSE = "LGPL-2.0-or-later"
3LIC_FILES_CHKSUM = "file://COPYING;md5=34c88b124db5fb2762c1676be7dadd36"
4
Patrick Williams7784c422022-11-17 07:29:11 -06005
6inherit gnomebase gsettings gobject-introspection gtk-icon-cache vala features_check
7
Patrick Williams8e7b46e2023-05-01 14:19:06 -05008DEPENDS = "gdk-pixbuf dbus glib-2.0"
Patrick Williams7784c422022-11-17 07:29:11 -06009
Patrick Williamsb542dec2023-06-09 01:26:37 -050010SRC_URI += "file://0001-Replace-filename-with-basename.patch"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050011SRC_URI[archive.sha256sum] = "418bb9fcffdbd72a98205ad365137617fc1e3551a54de74f6a98d45d266175bf"
Patrick Williams7784c422022-11-17 07:29:11 -060012
Patrick Williams8e7b46e2023-05-01 14:19:06 -050013PACKAGECONFIG ?= "goabackend kerberos owncloud lastfm google windows_live"
Patrick Williams7784c422022-11-17 07:29:11 -060014
Patrick Williams8e7b46e2023-05-01 14:19:06 -050015# goabackend requires webkitgtk to be built with gtk+3 and gcr3
Patrick Williams2a254922023-08-11 09:48:11 -050016PACKAGECONFIG[goabackend] = "-Dgoabackend=true,-Dgoabackend=false,gtk+3 gtk+3-native json-glib libxml2 libsoup rest libsecret webkitgtk3"
Andrew Geissler517393d2023-01-13 08:55:19 -060017PACKAGECONFIG[kerberos] = "-Dkerberos=true, -Dkerberos=false,krb5 gcr3"
Patrick Williams7784c422022-11-17 07:29:11 -060018PACKAGECONFIG[exchange] = "-Dexchange=true, -Dexchange=false"
19PACKAGECONFIG[google] = "-Dgoogle=true, -Dgoogle=false"
20PACKAGECONFIG[owncloud] = "-Downcloud=true, -Downcloud=false"
21PACKAGECONFIG[windows_live] = "-Dwindows_live=true, -Dwindows_live=false"
22PACKAGECONFIG[lastfm] = "-Dlastfm=true, -Dlastfm=false"
Patrick Williams7784c422022-11-17 07:29:11 -060023
24FILES:${PN} += " \
25 ${datadir}/dbus-1 \
26 ${libdir}/goa-1.0/web-extensions/*.so \
27"
28
29# looked into pkg-config file: it is not a bug - they mean it
30FILES:${PN}-dev += "${libdir}/goa-1.0/include"