blob: 63372afa5d17e4e8ceed5ef4c6b6aa9c7c46aa9c [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "library to access web services that claim to be "RESTful""
2HOMEPAGE = "https://wiki.gnome.org/Projects/Librest"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
5
6DEPENDS = " \
Andrew Geissler517393d2023-01-13 08:55:19 -06007 glib-2.0 \
8 glib-2.0-native \
Andrew Geissler517393d2023-01-13 08:55:19 -06009 libsoup-2.4 \
Patrick Williams169d7bc2024-01-05 11:33:25 -060010 libxml2 \
Andrew Geissler517393d2023-01-13 08:55:19 -060011"
12
Patrick Williamsac13d5f2023-11-24 18:59:46 -060013GNOMEBASEBUILDCLASS = "autotools"
Patrick Williams169d7bc2024-01-05 11:33:25 -060014inherit gnomebase gobject-introspection vala pkgconfig gtk-doc
Andrew Geissler517393d2023-01-13 08:55:19 -060015
16GNOMEBN = "rest"
17
18SRC_URI[archive.sha256sum] = "0513aad38e5d3cedd4ae3c551634e3be1b9baaa79775e53b2dba9456f15b01c9"
19
20S = "${WORKDIR}/${GNOMEBN}-${PV}"
21# * gnome environment requires libsoup build with in gnome PACKAGECONFIG
22# * libsoup-gnome support was removed upstream three years ago [1]
23# [1] https://gitlab.gnome.org/GNOME/librest/commit/8f904a8e2bb38a7bf72245cdf2f1ecad17e9a720
24EXTRA_OECONF = "--without-gnome"
25
26do_configure:prepend() {
27 # rest expects introspection.m4 at custom location (see aclocal.m4).
28 cp -f ${STAGING_DIR_TARGET}/${datadir}/aclocal/introspection.m4 ${S}/build
29}
30
31do_compile:prepend() {
32 export GIR_EXTRA_LIBS_PATH="${B}/rest/.libs"
33}