Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "library to access web services that claim to be "RESTful"" |
| 2 | HOMEPAGE = "https://wiki.gnome.org/Projects/Librest" |
| 3 | LICENSE = "LGPL-2.1-only" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1" |
| 5 | |
| 6 | DEPENDS = " \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 7 | glib-2.0 \ |
| 8 | glib-2.0-native \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 9 | libsoup-2.4 \ |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 10 | libxml2 \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 11 | " |
| 12 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 13 | GNOMEBASEBUILDCLASS = "autotools" |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 14 | inherit gnomebase gobject-introspection vala pkgconfig gtk-doc |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 15 | |
| 16 | GNOMEBN = "rest" |
| 17 | |
| 18 | SRC_URI[archive.sha256sum] = "0513aad38e5d3cedd4ae3c551634e3be1b9baaa79775e53b2dba9456f15b01c9" |
| 19 | |
| 20 | S = "${WORKDIR}/${GNOMEBN}-${PV}" |
| 21 | # * gnome environment requires libsoup build with in gnome PACKAGECONFIG |
| 22 | # * libsoup-gnome support was removed upstream three years ago [1] |
| 23 | # [1] https://gitlab.gnome.org/GNOME/librest/commit/8f904a8e2bb38a7bf72245cdf2f1ecad17e9a720 |
| 24 | EXTRA_OECONF = "--without-gnome" |
| 25 | |
| 26 | do_configure:prepend() { |
| 27 | # rest expects introspection.m4 at custom location (see aclocal.m4). |
| 28 | cp -f ${STAGING_DIR_TARGET}/${datadir}/aclocal/introspection.m4 ${S}/build |
| 29 | } |
| 30 | |
| 31 | do_compile:prepend() { |
| 32 | export GIR_EXTRA_LIBS_PATH="${B}/rest/.libs" |
| 33 | } |