Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Wireless daemon for Linux" |
| 2 | HOMEPAGE = "https://iwd.wiki.kernel.org/" |
| 3 | LICENSE = "LGPL-2.1-only" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09" |
| 5 | |
| 6 | DEPENDS = "ell" |
| 7 | |
| 8 | SRC_URI = "https://www.kernel.org/pub/linux/network/wireless/${BP}.tar.xz \ |
| 9 | file://0001-build-Use-abs_top_srcdir-instead-of-abs_srcdir-for-e.patch \ |
| 10 | " |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "a90e621f45b9c2f9021beea0fa6477ee0334fcd2ee34beaab42e31ea0fd3be29" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 12 | |
| 13 | inherit autotools manpages pkgconfig python3native systemd |
| 14 | |
| 15 | PACKAGECONFIG ??= " \ |
| 16 | client \ |
| 17 | monitor \ |
| 18 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
| 19 | " |
| 20 | PACKAGECONFIG[client] = "--enable-client,--disable-client,readline" |
| 21 | PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor" |
| 22 | PACKAGECONFIG[manpages] = "--enable-manual-pages,--disable-manual-pages,python3-docutils-native" |
| 23 | PACKAGECONFIG[wired] = "--enable-wired,--disable-wired" |
| 24 | PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono" |
| 25 | PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd" |
| 26 | |
| 27 | EXTRA_OECONF = "--enable-external-ell" |
| 28 | |
| 29 | SYSTEMD_SERVICE:${PN} = " \ |
| 30 | iwd.service \ |
| 31 | ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)} \ |
| 32 | " |
| 33 | |
| 34 | do_configure:prepend() { |
| 35 | install -d ${S}/build-aux |
| 36 | } |
| 37 | |
| 38 | do_install:append() { |
| 39 | # If client and monitor are disabled, bindir is empty, causing a QA error |
| 40 | rmdir --ignore-fail-on-non-empty ${D}/${bindir} |
| 41 | } |
| 42 | |
| 43 | FILES:${PN} += " \ |
| 44 | ${datadir}/dbus-1 \ |
| 45 | ${nonarch_libdir}/modules-load.d \ |
| 46 | ${systemd_unitdir}/network \ |
| 47 | " |
| 48 | |
| 49 | RDEPENDS:${PN} = "dbus" |
| 50 | |
| 51 | RRECOMMENDS:${PN} = "\ |
| 52 | kernel-module-pkcs7-message \ |
| 53 | kernel-module-pkcs8-key-parser \ |
| 54 | kernel-module-x509-key-parser \ |
| 55 | " |