blob: a88042ba65c68437413f15e4f40606ad6dad1d64 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Linux tool to dump x86 CPUID information about the CPU(s)"
2DESCRIPTION = "cpuid dumps detailed information about the CPU(s) gathered \
3from the CPUID instruction, and also determines the exact model of CPU(s). \
4It supports Intel, AMD, and VIA CPUs, as well as older Transmeta, Cyrix, \
5UMC, NexGen, Rise, and SiS CPUs"
6HOMEPAGE="http://www.etallen.com/cpuid.html"
7LICENSE = "GPL-2.0-only"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
9
10SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz \
11 "
12SRC_URI[sha256sum] = "b1c83045efc26076307751e0662d580277f5f9bf89cf027231a7812003c3a4e8"
13
14COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
15
16inherit perlnative
17
18# The install rule from the Makefile has hardcoded paths, so we duplicate
19# the actions to accommodate different paths.
20do_install () {
21 install -D -m 0755 ${B}/cpuid ${D}/${bindir}/cpuid
22 install -D -m 0444 ${B}/cpuid.man.gz ${D}/${mandir}
23}