Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 1 | SUMMARY = "Low-Level Interface to lzma compresion library." |
| 2 | DESCRIPTION = "This module provides a Perl interface to allow reading and \ |
| 3 | wrting of lzma, lzip and xz files/buffers." |
| 4 | HOMEPAGE = "https://metacpan.org/release/Compress-Raw-Lzma" |
| 5 | SECTION = "libs" |
| 6 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
| 7 | |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://README;beginline=8;endline=10;md5=b95311d4a7dbf3d0d3663edc094aced6" |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 9 | |
| 10 | SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/Compress-Raw-Lzma-${PV}.tar.gz" |
| 11 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 12 | SRC_URI[sha256sum] = "e01a7040b84bdc67592d13eec0c788590e1f696d1d4f07c7097bd72a4f886eb4" |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 13 | |
| 14 | DEPENDS += "xz" |
| 15 | |
| 16 | S = "${WORKDIR}/Compress-Raw-Lzma-${PV}" |
| 17 | |
| 18 | inherit cpan |
| 19 | |
| 20 | RDEPENDS:${PN} += "\ |
| 21 | perl-module-universal \ |
| 22 | " |
| 23 | |
| 24 | export LIBLZMA_INCLUDE="-I${STAGING_DIR_HOST}${includedir}" |
| 25 | export LIBLZMA_LIB="-I${STAGING_DIR_HOST}${libdir}" |
| 26 | |
| 27 | do_compile() { |
| 28 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 29 | cpan_do_compile |
| 30 | } |
| 31 | |
| 32 | BBCLASSEXTEND = "native" |