Lancelot Kao | c2c04b0 | 2021-02-22 22:55:06 -0600 | [diff] [blame] | 1 | SUMMARY = "foxconn OEM IPMI commands" |
| 2 | DESCRIPTION = "foxconn OEM IPMI commands" |
| 3 | |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 6 | |
| 7 | S = "${WORKDIR}/git" |
| 8 | |
| 9 | DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd libgpiod" |
| 10 | |
| 11 | inherit cmake obmc-phosphor-ipmiprovider-symlink |
| 12 | |
| 13 | EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1" |
| 14 | |
| 15 | LIBRARY_NAMES = "libfiioemcmds.so" |
| 16 | |
| 17 | SRC_URI = "git://github.com/openbmc/foxconn-ipmi-oem.git" |
Andrew Geissler | 9cb3a7c | 2021-06-23 16:40:11 +0000 | [diff] [blame] | 18 | SRCREV = "35c1ac40e476caa19c84a546d4f85ba96cb5dbbd" |
Lancelot Kao | c2c04b0 | 2021-02-22 22:55:06 -0600 | [diff] [blame] | 19 | |
| 20 | HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}" |
| 21 | NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}" |
| 22 | |
Mohaimen Alsamarai | f59d017 | 2021-08-17 09:34:22 -0500 | [diff] [blame^] | 23 | FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 24 | FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 25 | FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 26 | FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}" |