Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 1 | inherit esw python3native |
2 | |||||
3 | ESW_COMPONENT_SRC = "/lib/bsp/standalone/src/" | ||||
4 | ESW_COMPONENT_NAME = "libxilstandalone.a" | ||||
5 | |||||
6 | DEPENDS += "dtc-native python3-dtc-native python3-pyyaml-native libgloss device-tree" | ||||
7 | |||||
8 | do_configure_prepend() { | ||||
9 | # This script should also not rely on relative paths and such | ||||
10 | cd ${S} | ||||
11 | nativepython3 ${S}/scripts/generate_libdata.py -d ${DTBFILE} | ||||
12 | } |