Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "netkit-rusers includes rusers - Displays who is logged in to machines on local network \ |
| 2 | rusersd - Logged in users server" |
| 3 | HOMEPAGE = "ftp://ftp.uk.linux.org/pub/linux/Networking/netkit" |
| 4 | SECTION = "net" |
| 5 | LICENSE = "BSD" |
| 6 | LIC_FILES_CHKSUM = "file://rusers/rusers.c;beginline=2;endline=3;md5=f4fc634a4ce8c569911196b72b10770e" |
| 7 | DEPENDS = " tcp-wrappers libtirpc rpcbind" |
| 8 | |
Brad Bishop | 7f28bc5 | 2017-12-03 23:42:40 -0500 | [diff] [blame] | 9 | SRC_URI = "http://http.debian.net/debian/pool/main/n/${BPN}/${BPN}_${PV}.orig.tar.gz;name=archive \ |
| 10 | http://http.debian.net/debian/pool/main/n/${BPN}/${BPN}_${PV}-8.diff.gz;name=patch8 \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | file://rpc.rusersd-Makefile-fix-parallel-build-issue.patch \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI[archive.md5sum] = "dc99a80b9fde2ab427c874f88f1c1602" |
| 15 | SRC_URI[archive.sha256sum] = "f00138651865ad2dcfec5dedda0cda403cb80c4ab68efcc3bbccafe198c24b6d" |
| 16 | SRC_URI[patch8.md5sum] = "1ff498113e0f920d92088092e5570bdc" |
| 17 | SRC_URI[patch8.sha256sum] = "14882dbdda4e37baa84d55b54b46c7e063a20fc9e04d1be1a2807643cd0f3067" |
| 18 | |
| 19 | inherit autotools-brokensep |
| 20 | |
| 21 | do_configure () { |
| 22 | ./configure --prefix=${prefix} |
| 23 | echo "LDFLAGS=${LDFLAGS}" >> MCONFIG |
| 24 | echo "USE_GLIBC=1" >> MCONFIG |
| 25 | } |
| 26 | |
| 27 | do_install () { |
| 28 | install -d ${D}${bindir} |
| 29 | install -d ${D}${sbindir} |
| 30 | install -d ${D}${mandir}/man1 |
| 31 | install -d ${D}${mandir}/man8 |
| 32 | install -d ${D}${sysconfdir}/xinetd.d |
| 33 | |
| 34 | sed -i 's/install -s/install/' rusers/Makefile |
| 35 | sed -i 's/install -s/install/' rup/Makefile |
| 36 | sed -i 's/install -s/install/' rpc.rusersd/Makefile |
| 37 | |
| 38 | oe_runmake 'INSTALLROOT=${D}' 'BINMODE=0755' \ |
| 39 | 'DAEMONMODE=0755' 'MANMODE=0644' \ |
| 40 | 'BINDIR=${bindir}' 'SBINDIR=${sbindir}' \ |
| 41 | 'MANDIR=${mandir}' install |
| 42 | |
| 43 | # create the xinetd config file |
| 44 | cat >rusersd.conf <<EOF |
| 45 | service rusersd |
| 46 | { |
| 47 | disable = yes |
| 48 | type = RPC |
| 49 | rpc_version = 1-2 |
| 50 | socket_type = dgram |
| 51 | protocol = udp |
| 52 | wait = yes |
| 53 | user = root |
| 54 | server = ${sbindir}/rpc.rusersd |
| 55 | } |
| 56 | EOF |
| 57 | install rusersd.conf ${D}/${sysconfdir}/xinetd.d/rusersd |
| 58 | } |
| 59 | |
| 60 | |
| 61 | INSANE_SKIP_${PN} = "already-stripped" |
| 62 | |
| 63 | PACKAGES = "${PN}-client ${PN}-server ${PN}-doc ${BPN}-dbg" |
| 64 | FILES_${PN}-client = "${bindir}/*" |
| 65 | FILES_${PN}-server = "${sbindir}/* ${sysconfdir}" |
| 66 | FILES_${PN}-doc = "${mandir}" |
| 67 | FILES_${PN}-dbg = "${prefix}/src/debug \ |
| 68 | ${bindir}/.debug ${sbindir}/.debug" |
| 69 | |
| 70 | RDEPENDS_${PN}-server = "tcp-wrappers xinetd rpcbind" |