Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 1 | SUMMARY = "smemstat reports the physical memory usage taking into consideration shared memory" |
| 2 | HOMEPAGE = "https://github.com/ColinIanKing/smemstat" |
| 3 | LICENSE = "GPL-2.0-or-later" |
| 4 | |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 6 | |
| 7 | DEPENDS = "ncurses" |
| 8 | |
| 9 | SRC_URI = "git://github.com/ColinIanKing/smemstat.git;protocol=https;branch=master" |
| 10 | SRCREV = "9eea7504ab33783d804c4ed9237e299effb68874" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | inherit bash-completion |
| 15 | |
| 16 | do_compile () { |
| 17 | oe_runmake smemstat |
| 18 | } |
| 19 | |
| 20 | do_install () { |
| 21 | oe_runmake DESTDIR=${D} install |
| 22 | } |