blob: cff654a06c0d090f23bf3f3c8a145108432075a2 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Vulkan Header files and API registry"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Vulkan is a 3D graphics and compute API providing cross-platform access \
3to modern GPUs with low overhead and targeting realtime graphics applications such as \
4games and interactive media. This package contains the development headers \
5for packages wanting to make use of Vulkan."
Andrew Geissler82c905d2020-04-13 13:39:40 -05006HOMEPAGE = "https://www.khronos.org/vulkan/"
7BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Headers"
8SECTION = "libs"
9
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
Andrew Geisslerd25ed322020-06-27 00:28:28 -050012SRC_URI = "git://github.com/KhronosGroup/Vulkan-Headers.git;branch=master"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
William A. Kennington IIIac69b482021-06-02 12:28:27 -070014SRCREV = "074fa3055cfee530992bcbfa0fcb23106a82c1ab"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015
16S = "${WORKDIR}/git"
17
18inherit cmake
19
20FILES_${PN} += "${datadir}/vulkan"
21
22UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"