Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 1 | DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/" |
| 3 | LICENSE = "LGPL-2.1+" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36" |
| 5 | SECTION = "net" |
| 6 | |
| 7 | DEPENDS = "file" |
| 8 | |
| 9 | SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz" |
| 10 | SRC_URI[md5sum] = "2b15949b1633e4fa487e08cdcc97f0e3" |
| 11 | SRC_URI[sha256sum] = "a37b2f1b88fd1bfe74109586be463a434d34e773530fc2a74364cfcf734c032e" |
| 12 | |
| 13 | inherit autotools lib_package pkgconfig gettext |
| 14 | |
| 15 | CFLAGS += "-pthread -D_REENTRANT" |
| 16 | |
| 17 | EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../" |
| 18 | |
| 19 | PACKAGECONFIG ?= "curl https" |
| 20 | PACKAGECONFIG_append_class-target = "\ |
| 21 | ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \ |
| 22 | " |
| 23 | PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,," |
| 24 | PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl," |
| 25 | PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls," |
| 26 | |
| 27 | do_compile_append() { |
| 28 | sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc |
| 29 | } |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |