Andrew Geissler | e34f896 | 2021-04-15 15:53:51 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Parallelism library for C++ - runtime files \ |
| 2 | TBB is a library that helps you leverage multi-core processor \ |
| 3 | performance without having to be a threading expert. It represents a \ |
| 4 | higher-level, task-based parallelism that abstracts platform details \ |
| 5 | and threading mechanism for performance and scalability." |
| 6 | HOMEPAGE = "https://software.intel.com/en-us/tbb" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=86d3f3a95c324c9479bd8986968f4327" |
| 9 | |
| 10 | DEPENDS_append_libc-musl = " libucontext" |
| 11 | |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 12 | PE = "1" |
| 13 | |
Andrew Geissler | e34f896 | 2021-04-15 15:53:51 -0500 | [diff] [blame] | 14 | BRANCH = "onetbb_2021" |
| 15 | SRCREV = "2dba2072869a189b9fdab3ffa431d3ea49059a19" |
| 16 | SRC_URI = "git://github.com/oneapi-src/oneTBB.git;protocol=https;branch=${BRANCH} \ |
| 17 | file://0001-mallinfo-is-glibc-specific-API-mark-it-so.patch \ |
| 18 | file://GLIBC-PREREQ-is-not-defined-on-musl.patch \ |
| 19 | file://0001-CMakeLists.txt-exclude-riscv64-riscv32.patch \ |
| 20 | file://0001-Disable-use-of-_tpause-instruction.patch \ |
| 21 | " |
| 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | inherit cmake |
| 26 | |
| 27 | # test build fails, error: 'mallinfo mallinfo()' is deprecated |
| 28 | EXTRA_OECMAKE += " \ |
| 29 | -DTBB_TEST=OFF \ |
| 30 | -DCMAKE_BUILD_TYPE=Release \ |
| 31 | " |
| 32 | |
| 33 | |
| 34 | # fails with thumb enabled: |
| 35 | # | arm-oe-linux-gnueabi-g++ -march=armv7-a -mthumb -mthumb-interwork -mfloat-abi=softfp -mfpu=neon -mtune=cortex-a9 -mcpu=cortex-a9 -D__ARM__ -D__LINUX_ARM_ARCH__=7 -funwind-tables -mvectorize-with-neon-quad -rdynamic --sysroot=/OE/sysroots/m14tv -c -MMD -DTBB_USE_DEBUG -g -O0 -DUSE_PTHREAD -fPIC -D__TBB_BUILD=1 -Wall -Wno-parentheses -Wno-non-virtual-dtor -O2 -pipe -g -feliminate-unused-debug-types -fpermissive -fvisibility-inlines-hidden -I../../src -I../../src/rml/include -I../../include ../../src/tbb/concurrent_queue.cpp |
| 36 | # | {standard input}: Assembler messages: |
| 37 | # | {standard input}:250: Error: thumb conditional instruction should be in IT block -- `strexeq r2,r3,[r4]' |
| 38 | # ... |
| 39 | # | make[1]: *** [concurrent_queue.o] Error 1 |
| 40 | ARM_INSTRUCTION_SET = "arm" |
| 41 | |
| 42 | ASNEEDED = "" |
| 43 | |
| 44 | LDFLAGS_append_mips = " -latomic" |
| 45 | LDFLAGS_append_mipsel = " -latomic" |
| 46 | |
| 47 | LDFLAGS_append_libc-musl = " -lucontext" |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 48 | |
| 49 | # The latest version of oneTBB does not support PPC |
| 50 | COMPATIBLE_MACHINE_powerpc = "(!.*ppc).*" |