Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "JSON C++ lib used to read and write json file." |
| 2 | DESCRIPTION = "Jsoncpp is an implementation of a JSON (http://json.org) reader \ |
| 3 | and writer in C++. JSON (JavaScript Object Notation) is a \ |
| 4 | lightweight data-interchange format. It is easy for humans to \ |
| 5 | read and write. It is easy for machines to parse and generate." |
| 6 | |
| 7 | HOMEPAGE = "https://github.com/open-source-parsers/jsoncpp" |
| 8 | |
| 9 | SECTION = "libs" |
| 10 | |
| 11 | LICENSE = "MIT" |
| 12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=fa2a23dd1dc6c139f35105379d76df2b" |
| 13 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 14 | PE = "1" |
| 15 | |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 16 | SRCREV = "6aba23f4a8628d599a9ef7fa4811c4ff6e4070e2" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 17 | SRC_URI = "git://github.com/open-source-parsers/jsoncpp" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | inherit cmake |
| 22 | |
| 23 | EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON -DJSONCPP_WITH_TESTS=OFF" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 24 | |
| 25 | BBCLASSEXTEND = "native" |