Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | # NOTE: mosh-server requires a UTF-8 locale, but there's no way to add |
| 2 | # an explicit dependency for this so you need to ensure this is in your |
| 3 | # image yourself when you install mosh-server. |
| 4 | |
| 5 | SUMMARY = "Remote shell supporting roaming and high-latency connections" |
| 6 | DESCRIPTION = "Remote terminal application that allows roaming, supports \ |
| 7 | intermittent connectivity, and provides intelligent local echo and line \ |
| 8 | editing of user keystrokes. Mosh is a replacement for SSH. It's more \ |
| 9 | robust and responsive, especially over Wi-Fi, cellular, and \ |
| 10 | long-distance links." |
| 11 | HOMEPAGE = "http://mosh.mit.edu" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 12 | LICENSE = "GPL-3.0-or-later" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 14 | |
| 15 | DEPENDS = "protobuf-native protobuf ncurses zlib libio-pty-perl openssl libutempter" |
| 16 | |
| 17 | SRC_URI = "http://mosh.mit.edu/mosh-${PV}.tar.gz \ |
| 18 | file://0001-Fix-building-with-libc.patch \ |
| 19 | " |
| 20 | SRC_URI[md5sum] = "5122f4d2b973ab7c38dcdac8c35cb61e" |
| 21 | SRC_URI[sha256sum] = "da600573dfa827d88ce114e0fed30210689381bbdcff543c931e4d6a2e851216" |
| 22 | |
| 23 | inherit autotools pkgconfig |
| 24 | |
| 25 | PACKAGE_BEFORE_PN += "${PN}-server" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | FILES:${PN}-server = "${bindir}/mosh-server" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 27 | |
| 28 | NEEDED_PERL_MODULES = "\ |
| 29 | perl-module-socket \ |
| 30 | perl-module-getopt-long \ |
| 31 | perl-module-errno \ |
| 32 | perl-module-io-socket-inet \ |
| 33 | perl-module-posix \ |
| 34 | " |
| 35 | |
| 36 | # mosh uses SSH to authenticate and the client uses OpenSSH-specific features |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | RDEPENDS:${PN} += "openssh-ssh ${NEEDED_PERL_MODULES}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 38 | # The server seemed not to work with dropbear either |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 39 | RDEPENDS:${PN}-server += "openssh-sshd" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 40 | |
| 41 | # Fails to build with thumb-1 (qemuarm) |
| 42 | #| {standard input}: Assembler messages: |
| 43 | #| {standard input}:2100: Error: instruction not supported in Thumb16 mode -- `adds r4,r4,r4' |
| 44 | #| {standard input}:2101: Error: instruction not supported in Thumb16 mode -- `adcs r5,r5,r5' |
| 45 | #| {standard input}:2102: Error: instruction not supported in Thumb16 mode -- `adcs r6,r6,r6' |
| 46 | #| {standard input}:2103: Error: instruction not supported in Thumb16 mode -- `adcs r7,r7,r7' |
| 47 | #| {standard input}:2104: Error: selected processor does not support Thumb mode `it cs' |
| 48 | ARM_INSTRUCTION_SET = "arm" |