Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | DESCRIPTION = "C++ client for Redis based on hiredis" |
| 2 | HOMEPAGE = "https://github.com/sewenew/redis-plus-plus" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 6 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 7 | SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https \ |
| 8 | file://0001-cmake-Use-CMAKE_INSTALL_LIBDIR-from-GNUInstallDirs.patch \ |
| 9 | " |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 10 | SRCREV = "389ffdf9e72035ea2096b03cda7f4a6809ae6363" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | inherit cmake |
| 15 | |
| 16 | DEPENDS += "hiredis" |
| 17 | |
| 18 | RDEPENDS:${PN} += "hiredis" |
| 19 | |
| 20 | FILES_SOLIBSDEV = "" |
| 21 | FILES:${PN} += " ${libdir}/libredis++.so*" |
| 22 | |
| 23 | INSANE_SKIP:${PN} += "dev-so" |