Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Simple helloworld application -- selftest variant" |
| 2 | SECTION = "examples" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" |
| 5 | |
| 6 | SRC_URI = "file://helloworld.c" |
| 7 | |
| 8 | S = "${WORKDIR}" |
| 9 | |
| 10 | do_compile() { |
| 11 | ${CC} ${CFLAGS} ${LDFLAGS} helloworld.c -o helloworld |
| 12 | } |
| 13 | |
| 14 | do_install() { |
| 15 | install -d ${D}${bindir} |
| 16 | install -m 0755 helloworld ${D}${bindir} |
| 17 | } |
| 18 | |
| 19 | BBCLASSEXTEND = "native nativesdk" |