blob: 6981d40be1a1740e1d1d551ead5caab15e6fd8d5 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001# Copyright (C) 2013 - 2016 Intel Corporation
2#
3# Released under the MIT license (see COPYING.MIT)
4
5# testsdk.bbclass enables testing for SDK and Extensible SDK
6#
Brad Bishop37a0e4d2017-12-04 01:01:44 -05007# To run SDK tests, run the commands:
8# $ bitbake <image-name> -c populate_sdk
9# $ bitbake <image-name> -c testsdk
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050010#
Brad Bishop37a0e4d2017-12-04 01:01:44 -050011# To run eSDK tests, run the commands:
12# $ bitbake <image-name> -c populate_sdk_ext
13# $ bitbake <image-name> -c testsdkext
14#
15# where "<image-name>" is an image like core-image-sato.
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050016
Brad Bishopf86d0552018-12-04 14:18:15 -080017def get_sdk_configuration(d, test_type):
18 import platform
19 from oeqa.utils.metadata import get_layers
20 configuration = {'TEST_TYPE': test_type,
21 'MACHINE': d.getVar("MACHINE"),
22 'SDKMACHINE': d.getVar("SDKMACHINE"),
23 'IMAGE_BASENAME': d.getVar("IMAGE_BASENAME"),
24 'IMAGE_PKGTYPE': d.getVar("IMAGE_PKGTYPE"),
25 'STARTTIME': d.getVar("DATETIME"),
26 'HOST_DISTRO': ('-'.join(platform.linux_distribution())).replace(' ', '-'),
27 'LAYERS': get_layers(d.getVar("BBLAYERS"))}
28 return configuration
29get_sdk_configuration[vardepsexclude] = "DATETIME"
30
31def get_sdk_json_result_dir(d):
32 json_result_dir = os.path.join(d.getVar("LOG_DIR"), 'oeqa')
33 custom_json_result_dir = d.getVar("OEQA_JSON_RESULT_DIR")
34 if custom_json_result_dir:
35 json_result_dir = custom_json_result_dir
36 return json_result_dir
37
38def get_sdk_result_id(configuration):
39 return '%s_%s_%s_%s_%s' % (configuration['TEST_TYPE'], configuration['IMAGE_BASENAME'], configuration['SDKMACHINE'], configuration['MACHINE'], configuration['STARTTIME'])
40
Brad Bishop6e60e8b2018-02-01 10:27:11 -050041def testsdk_main(d):
42 import os
43 import subprocess
44 import json
45 import logging
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050046
Brad Bishop6e60e8b2018-02-01 10:27:11 -050047 from bb.utils import export_proxies
Brad Bishop6e60e8b2018-02-01 10:27:11 -050048 from oeqa.sdk.context import OESDKTestContext, OESDKTestContextExecutor
49 from oeqa.utils import make_logger_bitbake_compatible
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050050
Brad Bishop6e60e8b2018-02-01 10:27:11 -050051 pn = d.getVar("PN")
52 logger = make_logger_bitbake_compatible(logging.getLogger("BitBake"))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050053
Brad Bishop6e60e8b2018-02-01 10:27:11 -050054 # sdk use network for download projects for build
55 export_proxies(d)
56
57 tcname = d.expand("${SDK_DEPLOY}/${TOOLCHAIN_OUTPUTNAME}.sh")
58 if not os.path.exists(tcname):
59 bb.fatal("The toolchain %s is not built. Build it before running the tests: 'bitbake <image> -c populate_sdk' ." % tcname)
60
61 tdname = d.expand("${SDK_DEPLOY}/${TOOLCHAIN_OUTPUTNAME}.testdata.json")
62 test_data = json.load(open(tdname, "r"))
63
64 target_pkg_manifest = OESDKTestContextExecutor._load_manifest(
65 d.expand("${SDK_DEPLOY}/${TOOLCHAIN_OUTPUTNAME}.target.manifest"))
66 host_pkg_manifest = OESDKTestContextExecutor._load_manifest(
67 d.expand("${SDK_DEPLOY}/${TOOLCHAIN_OUTPUTNAME}.host.manifest"))
68
69 sdk_dir = d.expand("${WORKDIR}/testimage-sdk/")
70 bb.utils.remove(sdk_dir, True)
71 bb.utils.mkdirhier(sdk_dir)
72 try:
73 subprocess.check_output("cd %s; %s <<EOF\n./\nY\nEOF" % (sdk_dir, tcname), shell=True)
74 except subprocess.CalledProcessError as e:
75 bb.fatal("Couldn't install the SDK:\n%s" % e.output.decode("utf-8"))
76
77 fail = False
78 sdk_envs = OESDKTestContextExecutor._get_sdk_environs(sdk_dir)
79 for s in sdk_envs:
80 sdk_env = sdk_envs[s]
81 bb.plain("SDK testing environment: %s" % s)
82 tc = OESDKTestContext(td=test_data, logger=logger, sdk_dir=sdk_dir,
83 sdk_env=sdk_env, target_pkg_manifest=target_pkg_manifest,
84 host_pkg_manifest=host_pkg_manifest)
85
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050086 try:
Brad Bishop6e60e8b2018-02-01 10:27:11 -050087 tc.loadTests(OESDKTestContextExecutor.default_cases)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050088 except Exception as e:
89 import traceback
90 bb.fatal("Loading tests failed:\n%s" % traceback.format_exc())
91
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050092 result = tc.runTests()
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050093
Brad Bishop6e60e8b2018-02-01 10:27:11 -050094 component = "%s %s" % (pn, OESDKTestContextExecutor.name)
95 context_msg = "%s:%s" % (os.path.basename(tcname), os.path.basename(sdk_env))
Brad Bishopf86d0552018-12-04 14:18:15 -080096 configuration = get_sdk_configuration(d, 'sdk')
97 result.logDetails(get_sdk_json_result_dir(d),
98 configuration,
99 get_sdk_result_id(configuration))
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500100 result.logSummary(component, context_msg)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500101
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500102 if not result.wasSuccessful():
103 fail = True
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500104
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500105 if fail:
106 bb.fatal("%s - FAILED - check the task log and the commands log" % pn)
107
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500108testsdk_main[vardepsexclude] =+ "BB_ORIGENV"
109
110python do_testsdk() {
111 testsdk_main(d)
112}
113addtask testsdk
114do_testsdk[nostamp] = "1"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500115
116def testsdkext_main(d):
117 import os
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500118 import json
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500119 import subprocess
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500120 import logging
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500121
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500122 from bb.utils import export_proxies
123 from oeqa.utils import avoid_paths_in_environ, make_logger_bitbake_compatible, subprocesstweak
124 from oeqa.sdkext.context import OESDKExtTestContext, OESDKExtTestContextExecutor
125
126 pn = d.getVar("PN")
127 logger = make_logger_bitbake_compatible(logging.getLogger("BitBake"))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500128
129 # extensible sdk use network
130 export_proxies(d)
131
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500132 subprocesstweak.errors_have_output()
133
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500134 # extensible sdk can be contaminated if native programs are
135 # in PATH, i.e. use perl-native instead of eSDK one.
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500136 paths_to_avoid = [d.getVar('STAGING_DIR'),
137 d.getVar('BASE_WORKDIR')]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500138 os.environ['PATH'] = avoid_paths_in_environ(paths_to_avoid)
139
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500140 tcname = d.expand("${SDK_DEPLOY}/${TOOLCHAINEXT_OUTPUTNAME}.sh")
141 if not os.path.exists(tcname):
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500142 bb.fatal("The toolchain ext %s is not built. Build it before running the" \
143 " tests: 'bitbake <image> -c populate_sdk_ext' ." % tcname)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500144
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500145 tdname = d.expand("${SDK_DEPLOY}/${TOOLCHAINEXT_OUTPUTNAME}.testdata.json")
146 test_data = json.load(open(tdname, "r"))
147
148 target_pkg_manifest = OESDKExtTestContextExecutor._load_manifest(
149 d.expand("${SDK_DEPLOY}/${TOOLCHAINEXT_OUTPUTNAME}.target.manifest"))
150 host_pkg_manifest = OESDKExtTestContextExecutor._load_manifest(
151 d.expand("${SDK_DEPLOY}/${TOOLCHAINEXT_OUTPUTNAME}.host.manifest"))
152
153 sdk_dir = d.expand("${WORKDIR}/testsdkext/")
154 bb.utils.remove(sdk_dir, True)
155 bb.utils.mkdirhier(sdk_dir)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500156 try:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500157 subprocess.check_output("%s -y -d %s" % (tcname, sdk_dir), shell=True)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500158 except subprocess.CalledProcessError as e:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600159 msg = "Couldn't install the extensible SDK:\n%s" % e.output.decode("utf-8")
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500160 logfn = os.path.join(sdk_dir, 'preparing_build_system.log')
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600161 if os.path.exists(logfn):
162 msg += '\n\nContents of preparing_build_system.log:\n'
163 with open(logfn, 'r') as f:
164 for line in f:
165 msg += line
166 bb.fatal(msg)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500167
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500168 fail = False
169 sdk_envs = OESDKExtTestContextExecutor._get_sdk_environs(sdk_dir)
170 for s in sdk_envs:
171 bb.plain("Extensible SDK testing environment: %s" % s)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500172
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500173 sdk_env = sdk_envs[s]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500174
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500175 # Use our own SSTATE_DIR and DL_DIR so that updates to the eSDK come from our sstate cache
176 # and we don't spend hours downloading kernels for the kernel module test
177 # Abuse auto.conf since local.conf would be overwritten by the SDK
178 with open(os.path.join(sdk_dir, 'conf', 'auto.conf'), 'a+') as f:
179 f.write('SSTATE_MIRRORS += " \\n file://.* file://%s/PATH"\n' % test_data.get('SSTATE_DIR'))
180 f.write('SOURCE_MIRROR_URL = "file://%s"\n' % test_data.get('DL_DIR'))
Brad Bishop316dfdd2018-06-25 12:45:53 -0400181 f.write('INHERIT += "own-mirrors"\n')
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500182
183 # We need to do this in case we have a minimal SDK
Brad Bishop316dfdd2018-06-25 12:45:53 -0400184 subprocess.check_output(". %s > /dev/null; devtool sdk-install meta-extsdk-toolchain" % \
185 sdk_env, cwd=sdk_dir, shell=True, stderr=subprocess.STDOUT)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500186
187 tc = OESDKExtTestContext(td=test_data, logger=logger, sdk_dir=sdk_dir,
188 sdk_env=sdk_env, target_pkg_manifest=target_pkg_manifest,
189 host_pkg_manifest=host_pkg_manifest)
190
191 try:
192 tc.loadTests(OESDKExtTestContextExecutor.default_cases)
193 except Exception as e:
194 import traceback
195 bb.fatal("Loading tests failed:\n%s" % traceback.format_exc())
196
197 result = tc.runTests()
198
199 component = "%s %s" % (pn, OESDKExtTestContextExecutor.name)
200 context_msg = "%s:%s" % (os.path.basename(tcname), os.path.basename(sdk_env))
Brad Bishopf86d0552018-12-04 14:18:15 -0800201 configuration = get_sdk_configuration(d, 'sdkext')
202 result.logDetails(get_sdk_json_result_dir(d),
203 configuration,
204 get_sdk_result_id(configuration))
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500205 result.logSummary(component, context_msg)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500206
207 if not result.wasSuccessful():
208 fail = True
209
210 if fail:
211 bb.fatal("%s - FAILED - check the task log and the commands log" % pn)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500212
213testsdkext_main[vardepsexclude] =+ "BB_ORIGENV"
214
215python do_testsdkext() {
216 testsdkext_main(d)
217}
218addtask testsdkext
219do_testsdkext[nostamp] = "1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500220