blob: 14a7ca8dc91ce2e63fd37b086343506fad37d810 [file] [log] [blame]
Patrick Williams169d7bc2024-01-05 11:33:25 -06001#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7SUMMARY = "A C++ example compiled with meson."
8
9require cpp-example.inc
10
11SRC_URI += "\
12 file://meson.build \
13 file://meson.options \
14"
15
16inherit pkgconfig meson
17
18PACKAGECONFIG[failing_test] = "-DFAILING_TEST=enabled"
19
20FILES:${PN}-ptest += "${bindir}/test-mesonex"
21
22do_run_tests () {
23 meson test -C "${B}" --no-rebuild
24}
25do_run_tests[doc] = "Run meson test using qemu-user"
26
27addtask do_run_tests after do_compile