Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 1 | # |
| 2 | # Copyright OpenEmbedded Contributors |
| 3 | # |
| 4 | # SPDX-License-Identifier: MIT |
| 5 | # |
| 6 | |
| 7 | SUMMARY = "A C++ example compiled with meson." |
| 8 | |
| 9 | require cpp-example.inc |
| 10 | |
| 11 | SRC_URI += "\ |
| 12 | file://meson.build \ |
| 13 | file://meson.options \ |
| 14 | " |
| 15 | |
| 16 | inherit pkgconfig meson |
| 17 | |
| 18 | PACKAGECONFIG[failing_test] = "-DFAILING_TEST=enabled" |
| 19 | |
| 20 | FILES:${PN}-ptest += "${bindir}/test-mesonex" |
| 21 | |
| 22 | do_run_tests () { |
| 23 | meson test -C "${B}" --no-rebuild |
| 24 | } |
| 25 | do_run_tests[doc] = "Run meson test using qemu-user" |
| 26 | |
| 27 | addtask do_run_tests after do_compile |