Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 1 | SUMMARY = "Installation scripts and binaries for the Raspberry Pi 4 EEPROM" |
| 2 | DESCRIPTION = "This repository contains the rpi4 bootloader and scripts \ |
| 3 | for updating it in the spi eeprom" |
| 4 | LICENSE = "BSD-3-Clause & Broadcom-RPi" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f546ed4f47e9d4c1fe954ecc9d3ef4f3" |
| 6 | |
| 7 | SRC_URI = " \ |
| 8 | git://github.com/raspberrypi/rpi-eeprom.git;protocol=https;branch=master \ |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 9 | " |
| 10 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 11 | SRCREV = "f13b5789f56f65112e2b8aa58be43ebfcbedfe1d" |
| 12 | PV = "v2023.10.18-2712" |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | RDEPENDS:${PN} += " \ |
| 17 | coreutils \ |
| 18 | python3 \ |
| 19 | python3-pycryptodomex \ |
| 20 | openssl \ |
| 21 | xxd \ |
| 22 | pciutils \ |
| 23 | " |
| 24 | |
| 25 | inherit python3native |
| 26 | |
| 27 | do_install() { |
| 28 | install -d ${D}${bindir} |
| 29 | |
| 30 | # install executables |
| 31 | install -m 0755 ${S}/tools/vl805 ${D}${bindir} |
| 32 | install -m 0755 ${S}/rpi-eeprom-update ${D}${bindir} |
| 33 | install -m 0755 ${S}/rpi-eeprom-config ${D}${bindir} |
| 34 | install -m 0755 ${S}/rpi-eeprom-digest ${D}${bindir} |
| 35 | |
| 36 | # copy firmware files |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 37 | install -d ${D}${base_libdir}/firmware/raspberrypi/bootloader/default |
| 38 | install -d ${D}${base_libdir}/firmware/raspberrypi/bootloader/latest |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 39 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 40 | install -m 644 ${S}/firmware-2711/default/* ${D}${base_libdir}/firmware/raspberrypi/bootloader/default |
| 41 | install -m 644 ${S}/firmware-2711/latest/* ${D}${base_libdir}/firmware/raspberrypi/bootloader/latest |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 42 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 43 | ln -s default ${D}${base_libdir}/firmware/raspberrypi/bootloader/critical |
| 44 | ln -s latest ${D}${base_libdir}/firmware/raspberrypi/bootloader/stable |
| 45 | ln -s latest ${D}${base_libdir}/firmware/raspberrypi/bootloader/beta |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 46 | |
| 47 | # copy default config |
| 48 | install -d ${D}${sysconfdir}/default |
| 49 | install -D ${S}/rpi-eeprom-update-default ${D}${sysconfdir}/default/rpi-eeprom-update |
| 50 | } |
| 51 | |
| 52 | FILES:${PN} += "${base_libdir}/firmware/raspberrypi/bootloader/*" |
| 53 | |
| 54 | INHIBIT_PACKAGE_STRIP = "1" |
| 55 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" |
| 56 | |
| 57 | # vl805 tool sources are not available (yet), as it comes as a precompiled |
| 58 | # binary only. It has ARM architecture whereas target machine is Aarch64. We |
| 59 | # need to disable arch check for it otherwise it cannot packed. |
| 60 | QAPATHTEST[arch] = "" |
| 61 | |
| 62 | COMPATIBLE_MACHINE = "raspberrypi4|raspberrypi4-64" |