Patrick Williams | 8dd6848 | 2022-10-04 07:57:18 -0500 | [diff] [blame] | 1 | SUMMARY = "External system Cortex-M3 Firmware" |
| 2 | DESCRIPTION = "Firmware to be loaded and run in External System Harness in\ |
| 3 | support to the main application CPU." |
| 4 | HOMEPAGE = "https://git.linaro.org/landing-teams/working/arm/external-system.git" |
| 5 | DEPENDS = "gcc-arm-none-eabi-native" |
| 6 | INHIBIT_DEFAULT_DEPS="1" |
| 7 | LICENSE = "BSD-3-Clause & Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://license.md;md5=e44b2531cd6ffe9dece394dbe988d9a0 \ |
| 9 | file://cmsis/LICENSE.txt;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 10 | |
| 11 | SRC_URI = "gitsm://git.gitlab.arm.com/arm-reference-solutions/corstone1000/external_system/rtx.git;protocol=https;branch=master" |
| 12 | SRCREV = "8c9dca74b104ff6c9722fb0738ba93dd3719c080" |
| 13 | PV .= "+git${SRCPV}" |
| 14 | |
| 15 | COMPATIBLE_MACHINE = "(corstone1000)" |
| 16 | |
| 17 | # PRODUCT is passed to the Makefile to specify the platform to be used. |
| 18 | PRODUCT = "corstone-1000" |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | B = "${WORKDIR}/build" |
| 22 | |
| 23 | LDFLAGS[unexport] = "1" |
| 24 | |
| 25 | do_compile() { |
| 26 | oe_runmake -C ${S} V=y \ |
| 27 | BUILD_PATH=${B} \ |
| 28 | PRODUCT=${PRODUCT} \ |
| 29 | CROSS_COMPILE=arm-none-eabi- \ |
| 30 | all |
| 31 | } |
| 32 | |
| 33 | do_compile[cleandirs] = "${B}" |
| 34 | |
| 35 | do_install() { |
| 36 | install -D -p -m 0644 ${B}/product/${PRODUCT}/firmware/release/bin/firmware.bin ${D}/firmware/es_flashfw.bin |
| 37 | } |
| 38 | |
| 39 | FILES:${PN} = "/firmware" |
| 40 | SYSROOT_DIRS += "/firmware" |
| 41 | |
| 42 | inherit deploy |
| 43 | |
| 44 | do_deploy() { |
| 45 | cp -rf ${D}/firmware/* ${DEPLOYDIR}/ |
| 46 | } |
| 47 | addtask deploy after do_install |