Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "ZNC, an advanced IRC bouncer" |
| 2 | SECTION = "net" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 5 | |
| 6 | DEPENDS = "openssl zlib icu" |
| 7 | |
| 8 | PV = "1.6.0" |
| 9 | |
| 10 | SRC_URI = "git://github.com/znc/znc.git;name=znc \ |
| 11 | git://github.com/jimloco/Csocket.git;destsuffix=git/third_party/Csocket;name=Csocket \ |
| 12 | " |
| 13 | SRCREV_znc = "f47e8465efa4e1cd948b9caae93ac401b4355df8" |
| 14 | SRCREV_Csocket = "07b4437396122650e5b8fb3d014e820a5decf4ee" |
| 15 | |
| 16 | # This constructs a composite revision based on multiple SRCREV's. |
| 17 | # |
| 18 | SRCREV_FORMAT = "znc_Csocket" |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | inherit autotools-brokensep pkgconfig |
| 23 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 24 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 25 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
| 26 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 27 | # ZNC has a custom autogen.sh that states that this command is needed *and* expected to fail |
| 28 | do_configure_prepend() { |
| 29 | automake --add-missing || true |
| 30 | } |
| 31 | |
| 32 | do_install_append() { |
| 33 | sed -i 's/-fdebug-prefix-map[^ ]*//g; s#${STAGING_DIR_TARGET}##g' ${D}${libdir}/pkgconfig/*.pc |
| 34 | } |