Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Opensource Implementation of WS-Management" |
| 2 | DESCRIPTION = "Openwsman is a project intended to provide an open-source \ |
| 3 | implementation of the Web Services Management specipication \ |
| 4 | (WS-Management) and to expose system management information on the \ |
| 5 | Linux operating system using the WS-Management protocol. WS-Management \ |
| 6 | is based on a suite of web services specifications and usage \ |
| 7 | requirements that exposes a set of operations focused on and covers \ |
| 8 | all system management aspects. \ |
| 9 | Openwsman Server and service libraries" |
| 10 | HOMEPAGE = "http://www.openwsman.org/" |
| 11 | SECTION = "Applications/System" |
| 12 | |
| 13 | DEPENDS = "curl libxml2 openssl libpam" |
| 14 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 15 | inherit features_check |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 16 | REQUIRED_DISTRO_FEATURES = "pam" |
| 17 | |
Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame] | 18 | SRCREV = "d8eba6cb6682b59d84ca1da67a523520b879ade6" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 19 | |
| 20 | SRC_URI = "git://github.com/Openwsman/openwsman.git \ |
| 21 | file://libssl-is-required-if-eventint-supported.patch \ |
| 22 | file://openwsmand.service \ |
| 23 | file://0001-lock.c-Define-PTHREAD_MUTEX_RECURSIVE_NP-if-undefine.patch \ |
| 24 | " |
| 25 | |
| 26 | S = "${WORKDIR}/git" |
| 27 | |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 28 | LICENSE = "BSD-3-Clause" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 29 | LIC_FILES_CHKSUM = "file://COPYING;md5=d4f53d4c6cf73b9d43186ce3be6dd0ba" |
| 30 | |
| 31 | inherit systemd cmake pkgconfig python3native perlnative |
| 32 | |
| 33 | SYSTEMD_SERVICE_${PN} = "openwsmand.service" |
| 34 | SYSTEMD_AUTO_ENABLE = "disable" |
| 35 | |
| 36 | LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', " -fuse-ld=bfd ", '', d)}" |
| 37 | |
| 38 | EXTRA_OECMAKE = "-DBUILD_BINDINGS=NO \ |
| 39 | -DBUILD_LIBCIM=NO \ |
| 40 | -DBUILD_PERL=YES \ |
| 41 | -DBUILD_PYTHON3=YES \ |
| 42 | -DBUILD_PYTHON=NO \ |
| 43 | -DCMAKE_INSTALL_PREFIX=${prefix} \ |
| 44 | -DLIB=${baselib} \ |
| 45 | " |
| 46 | |
| 47 | do_configure_prepend() { |
| 48 | export STAGING_INCDIR=${STAGING_INCDIR} |
| 49 | export STAGING_LIBDIR=${STAGING_LIBDIR} |
| 50 | } |
| 51 | |
| 52 | do_install_append() { |
| 53 | install -d ${D}/${sysconfdir}/init.d |
| 54 | install -m 755 ${B}/etc/init/openwsmand.sh ${D}/${sysconfdir}/init.d/openwsmand |
| 55 | ln -sf ${sysconfdir}/init.d/openwsmand ${D}/${sbindir}/rcopenwsmand |
| 56 | chmod 755 ${D}/${sysconfdir}/openwsman/owsmangencert.sh |
| 57 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
| 58 | install -d ${D}/${systemd_unitdir}/system |
| 59 | install -m 644 ${WORKDIR}/openwsmand.service ${D}/${systemd_unitdir}/system |
| 60 | |
| 61 | sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/openwsmand.service |
| 62 | sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/openwsmand.service |
| 63 | sed -i -e 's,@LOCALSTATEDIR@,${localstatedir},g' ${D}${systemd_unitdir}/system/openwsmand.service |
| 64 | fi |
| 65 | } |
| 66 | |
| 67 | FILES_${PN}-dbg += "${libdir}/openwsman/plugins/.debug/ \ |
| 68 | ${libdir}/openwsman/authenticators/.debug/ \ |
| 69 | " |
| 70 | |
| 71 | INSANE_SKIP_${PN} = "dev-so" |
| 72 | RDEPENDS_${PN} = "ruby" |