Artem Senichev | 8574e7e | 2020-05-08 12:33:35 +0300 | [diff] [blame] | 1 | SUMMARY = "Command-line interface" |
| 2 | DESCRIPTION = "YADRO OpenBMC Command Line Interface for end users" |
| 3 | HOMEPAGE = "https://github.com/YADRO-KNS/obmc-yadro-cli" |
| 4 | PR = "r1" |
| 5 | PV = "1.0+git${SRCPV}" |
| 6 | |
| 7 | # License info |
| 8 | LICENSE = "Apache-2.0" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 10 | |
| 11 | # Dependencies |
| 12 | DEPENDS = "phosphor-user-manager" |
| 13 | RDEPENDS_${PN} = "sudo bash" |
| 14 | |
Alexander Filippov | ad7324a | 2020-09-30 12:59:16 +0300 | [diff] [blame] | 15 | # Directory with command handlers |
| 16 | FILES_${PN} += "${datadir}/cli" |
Artem Senichev | 8574e7e | 2020-05-08 12:33:35 +0300 | [diff] [blame] | 17 | |
| 18 | # Custom installation procedure |
| 19 | do_install() { |
| 20 | ${B}/install.sh \ |
| 21 | --dir ${D} \ |
Alexander Filippov | ad7324a | 2020-09-30 12:59:16 +0300 | [diff] [blame] | 22 | --machine ${@'${MACHINE}'.split('-')[0]} \ |
Artem Senichev | 8574e7e | 2020-05-08 12:33:35 +0300 | [diff] [blame] | 23 | --admin priv-admin \ |
| 24 | --operator priv-operator \ |
| 25 | --user priv-user |
| 26 | } |
| 27 | |
| 28 | # Source code repository |
| 29 | S = "${WORKDIR}/git" |
| 30 | SRC_URI = "git://github.com/YADRO-KNS/obmc-yadro-cli" |
Alexander Filippov | ad7324a | 2020-09-30 12:59:16 +0300 | [diff] [blame] | 31 | SRCREV = "1b0347f2c638df21333c5479b4d3152cfc4b5ac1" |