blob: 38d3245d2036dcc8869843a48dd7753c3e5dbe44 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Enchant Spell checker API Library"
2DESCRIPTION = "A library (and command-line program) that wraps a number of \
3different spelling libraries and programs with a consistent interface."
4SECTION = "libs"
5HOMEPAGE = "https://abiword.github.io/enchant/"
6BUGTRACKER = "https://github.com/AbiWord/enchant/issues/"
7LICENSE = "LGPL-2.1-or-later"
8LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
9
10DEPENDS = "glib-2.0 groff-native"
11
12inherit autotools pkgconfig github-releases
13
14SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/enchant-${PV}.tar.gz"
15SRC_URI[sha256sum] = "6686a728e56e760f8dee09a22f0fb53b46ee9dbe7d64cf9e5bb35a658bff7e1d"
16
17GITHUB_BASE_URI = "https://github.com/AbiWord/enchant/releases"
18
19S = "${WORKDIR}/enchant-${PV}"
20
21EXTRA_OEMAKE = "pkgdatadir=${datadir}/enchant-2"
22
23PACKAGECONFIG ??= "aspell"
24PACKAGECONFIG[aspell] = "--with-aspell,--without-aspell,aspell,aspell"
25PACKAGECONFIG[hunspell] = "--with-hunspell,--without-hunspell,hunspell,hunspell"
26
27FILES:${PN} += " \
28 ${datadir}/enchant-2 \
29 ${libdir}/enchant-2 \
30"
31FILES:${PN}-staticdev += "${libdir}/enchant-2/*.a"