Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Enchant Spell checker API Library" |
| 2 | DESCRIPTION = "A library (and command-line program) that wraps a number of \ |
| 3 | different spelling libraries and programs with a consistent interface." |
| 4 | SECTION = "libs" |
| 5 | HOMEPAGE = "https://abiword.github.io/enchant/" |
| 6 | BUGTRACKER = "https://github.com/AbiWord/enchant/issues/" |
| 7 | LICENSE = "LGPL-2.1-or-later" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c" |
| 9 | |
| 10 | DEPENDS = "glib-2.0 groff-native" |
| 11 | |
| 12 | inherit autotools pkgconfig github-releases |
| 13 | |
| 14 | SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/enchant-${PV}.tar.gz" |
| 15 | SRC_URI[sha256sum] = "6686a728e56e760f8dee09a22f0fb53b46ee9dbe7d64cf9e5bb35a658bff7e1d" |
| 16 | |
| 17 | GITHUB_BASE_URI = "https://github.com/AbiWord/enchant/releases" |
| 18 | |
| 19 | S = "${WORKDIR}/enchant-${PV}" |
| 20 | |
| 21 | EXTRA_OEMAKE = "pkgdatadir=${datadir}/enchant-2" |
| 22 | |
| 23 | PACKAGECONFIG ??= "aspell" |
| 24 | PACKAGECONFIG[aspell] = "--with-aspell,--without-aspell,aspell,aspell" |
| 25 | PACKAGECONFIG[hunspell] = "--with-hunspell,--without-hunspell,hunspell,hunspell" |
| 26 | |
| 27 | FILES:${PN} += " \ |
| 28 | ${datadir}/enchant-2 \ |
| 29 | ${libdir}/enchant-2 \ |
| 30 | " |
| 31 | FILES:${PN}-staticdev += "${libdir}/enchant-2/*.a" |