AlanKuo | 20f7943 | 2020-11-02 09:35:28 +0800 | [diff] [blame] | 1 | SUMMARY = "Enable TLS with static CA" |
| 2 | DESCRIPTION = "Add static CA and only enable TLS authentication" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 5 | |
| 6 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
| 7 | |
| 8 | SRC_URI += "file://certs/authority/ \ |
| 9 | file://bmcweb_persistent_data.json \ |
| 10 | " |
| 11 | do_install(){ |
| 12 | install -d ${D}${sysconfdir}/ssl/certs/authority |
| 13 | install -m 0644 -D ${WORKDIR}/certs/authority/* \ |
| 14 | ${D}${sysconfdir}/ssl/certs/authority |
| 15 | |
| 16 | install -d ${D}${ROOT_HOME} |
| 17 | install -m 0640 ${WORKDIR}/bmcweb_persistent_data.json ${D}${ROOT_HOME} |
| 18 | } |
| 19 | |
| 20 | FILES_${PN} = "${ROOT_HOME}/bmcweb_persistent_data.json \ |
| 21 | ${sysconfdir}/ssl/certs/authority/* \ |
| 22 | " |