Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | require gstreamer1.0-plugins-common.inc |
| 2 | |
| 3 | SRC_URI = " \ |
| 4 | https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz \ |
| 5 | file://0001-qmlgl-ensure-Qt-defines-GLsync-to-fix-compile-on-som.patch \ |
| 6 | file://0001-qt-include-ext-qt-gstqtgl.h-instead-of-gst-gl-gstglf.patch \ |
| 7 | " |
| 8 | |
| 9 | SRC_URI[md5sum] = "bd025f8f14974f94b75ac69a9d1b9c93" |
| 10 | SRC_URI[sha256sum] = "40bb3bafda25c0b739c8fc36e48380fccf61c4d3f83747e97ac3f9b0171b1319" |
| 11 | |
| 12 | S = "${WORKDIR}/gst-plugins-good-${PV}" |
| 13 | |
| 14 | LICENSE = "GPLv2+ & LGPLv2.1+" |
| 15 | LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \ |
| 16 | file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607 \ |
| 17 | file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe" |
| 18 | |
| 19 | DEPENDS += "gstreamer1.0-plugins-base libcap zlib" |
| 20 | RPROVIDES_${PN}-pulseaudio += "${PN}-pulse" |
| 21 | RPROVIDES_${PN}-soup += "${PN}-souphttpsrc" |
| 22 | |
| 23 | PACKAGECONFIG ??= " \ |
| 24 | ${GSTREAMER_ORC} \ |
| 25 | ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio x11', d)} \ |
| 26 | bz2 cairo flac gdk-pixbuf gudev jpeg lame libpng mpg123 soup speex taglib v4l2 \ |
| 27 | " |
| 28 | |
| 29 | X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage" |
| 30 | X11ENABLEOPTS = "-Dximagesrc=enabled -Dximagesrc-xshm=enabled -Dximagesrc-xfixes=enabled -Dximagesrc-xdamage=enabled" |
| 31 | X11DISABLEOPTS = "-Dximagesrc=disabled -Dximagesrc-xshm=disabled -Dximagesrc-xfixes=disabled -Dximagesrc-xdamage=disabled" |
| 32 | |
| 33 | PACKAGECONFIG[bz2] = "-Dbz2=enabled,-Dbz2=disabled,bzip2" |
| 34 | PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo" |
| 35 | PACKAGECONFIG[dv1394] = "-Ddv1394=enabled,-Ddv1394=disabled,libiec61883 libavc1394 libraw1394" |
| 36 | PACKAGECONFIG[flac] = "-Dflac=enabled,-Dflac=disabled,flac" |
| 37 | PACKAGECONFIG[gdk-pixbuf] = "-Dgdk-pixbuf=enabled,-Dgdk-pixbuf=disabled,gdk-pixbuf" |
| 38 | PACKAGECONFIG[gtk] = "-Dgtk3=enabled,-Dgtk3=disabled,gtk+3" |
| 39 | PACKAGECONFIG[gudev] = "-Dv4l2-gudev=enabled,-Dv4l2-gudev=disabled,libgudev" |
| 40 | PACKAGECONFIG[jack] = "-Djack=enabled,-Djack=disabled,jack" |
| 41 | PACKAGECONFIG[jpeg] = "-Djpeg=enabled,-Djpeg=disabled,jpeg" |
| 42 | PACKAGECONFIG[lame] = "-Dlame=enabled,-Dlame=disabled,lame" |
| 43 | PACKAGECONFIG[libpng] = "-Dpng=enabled,-Dpng=disabled,libpng" |
| 44 | PACKAGECONFIG[libv4l2] = "-Dv4l2-libv4l2=enabled,-Dv4l2-libv4l2=disabled,v4l-utils" |
| 45 | PACKAGECONFIG[mpg123] = "-Dmpg123=enabled,-Dmpg123=disabled,mpg123" |
| 46 | PACKAGECONFIG[pulseaudio] = "-Dpulse=enabled,-Dpulse=disabled,pulseaudio" |
| 47 | PACKAGECONFIG[qt5] = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native" |
| 48 | PACKAGECONFIG[soup] = "-Dsoup=enabled,-Dsoup=disabled,libsoup-2.4" |
| 49 | PACKAGECONFIG[speex] = "-Dspeex=enabled,-Dspeex=disabled,speex" |
| 50 | PACKAGECONFIG[taglib] = "-Dtaglib=enabled,-Dtaglib=disabled,taglib" |
| 51 | PACKAGECONFIG[v4l2] = "-Dv4l2=enabled -Dv4l2-probe=true,-Dv4l2=disabled -Dv4l2-probe=false" |
| 52 | PACKAGECONFIG[vpx] = "-Dvpx=enabled,-Dvpx=disabled,libvpx" |
| 53 | PACKAGECONFIG[wavpack] = "-Dwavpack=enabled,-Dwavpack=disabled,wavpack" |
| 54 | PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}" |
| 55 | |
| 56 | EXTRA_OEMESON += " \ |
| 57 | -Daalib=disabled \ |
| 58 | -Ddirectsound=disabled \ |
| 59 | -Ddv=disabled \ |
| 60 | -Dlibcaca=disabled \ |
| 61 | -Doss=enabled \ |
| 62 | -Doss4=disabled \ |
| 63 | -Dosxaudio=disabled \ |
| 64 | -Dosxvideo=disabled \ |
| 65 | -Dshout2=disabled \ |
| 66 | -Dtwolame=disabled \ |
| 67 | -Dwaveform=disabled \ |
| 68 | " |
| 69 | |
| 70 | FILES_${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs" |