blob: 5197bf578f08d1360ed4f5dad3cdcdf38176aa48 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4HOMEPAGE = "https://lttng.org/"
5LICENSE = "LGPL-2.1-only & GPL-2.0-only & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4"
7
8inherit module
9
10include lttng-platforms.inc
11
Patrick Williams03907ee2022-05-01 06:28:52 -050012SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
Patrick Williams03907ee2022-05-01 06:28:52 -050013 file://0009-Rename-genhd-wrapper-to-blkdev.patch \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050014 file://0001-fix-mm-introduce-vma-vm_flags-wrapper-functions-v6.3.patch \
15 file://0002-fix-uuid-Decouple-guid_t-and-uuid_le-types-and-respe.patch \
16 file://0003-fix-btrfs-pass-find_free_extent_ctl-to-allocator-tra.patch \
17 file://0004-fix-net-add-location-to-trace_consume_skb-v6.3.patch \
Andrew Geissler615f2f12022-07-15 14:00:58 -050018 "
Patrick Williams03907ee2022-05-01 06:28:52 -050019
Andrew Geissler9aee5002022-03-30 16:27:02 +000020# Use :append here so that the patch is applied also when using devupstream
21SRC_URI:append = " file://0001-src-Kbuild-change-missing-CONFIG_TRACEPOINTS-to-warn.patch"
22
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050023SRC_URI[sha256sum] = "bf808b113544287cfe837a6382887fa66354ef5cc8216460cebbef3d27dc3581"
Andrew Geissler9aee5002022-03-30 16:27:02 +000024
25export INSTALL_MOD_DIR="kernel/lttng-modules"
26
27EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
28
29MODULES_MODULE_SYMVERS_LOCATION = "src"
30
31do_install:append() {
32 # Delete empty directories to avoid QA failures if no modules were built
33 if [ -d ${D}/${nonarch_base_libdir} ]; then
34 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
35 fi
36}
37
38python do_package:prepend() {
39 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
40 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
41}
42
43BBCLASSEXTEND = "devupstream:target"
44SRC_URI:class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.13"
45SRCREV:class-devupstream = "7584cfc04914cb0842a986e9808686858b9c8630"
46SRCREV_FORMAT ?= "lttng_git"