Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "A library for text mode user interfaces" |
| 2 | |
| 3 | DESCRIPTION = "Newt is a programming library for color text mode, widget based user \ |
| 4 | interfaces. Newt can be used to add stacked windows, entry widgets, \ |
| 5 | checkboxes, radio buttons, labels, plain text fields, scrollbars, \ |
| 6 | etc., to text mode user interfaces. This package also contains the \ |
| 7 | shared library needed by programs built with newt, as well as a \ |
| 8 | /usr/bin/dialog replacement called whiptail. Newt is based on the \ |
| 9 | slang library." |
| 10 | |
| 11 | HOMEPAGE = "https://releases.pagure.org/newt/" |
| 12 | SECTION = "libs" |
| 13 | |
| 14 | LICENSE = "LGPL-2.0-only" |
| 15 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 16 | |
| 17 | # slang needs to be >= 2.2 |
| 18 | DEPENDS = "slang popt python3" |
| 19 | |
| 20 | SRC_URI = "https://releases.pagure.org/newt/newt-${PV}.tar.gz \ |
| 21 | file://cross_ar.patch \ |
| 22 | file://Makefile.in-Add-tinfo-library-to-the-linking-librari.patch \ |
| 23 | file://0001-detect-gold-as-GNU-linker-too.patch \ |
| 24 | " |
| 25 | |
| 26 | SRC_URI[sha256sum] = "caa372907b14ececfe298f0d512a62f41d33b290610244a58aed07bbc5ada12a" |
| 27 | |
| 28 | S = "${WORKDIR}/newt-${PV}" |
| 29 | |
| 30 | inherit autotools-brokensep python3native python3-dir python3targetconfig |
| 31 | |
| 32 | EXTRA_OECONF = "--without-tcl --with-python" |
| 33 | |
| 34 | EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}" |
| 35 | |
| 36 | CLEANBROKEN = "1" |
| 37 | |
| 38 | export CPPFLAGS |
| 39 | |
| 40 | PACKAGES:prepend = "whiptail ${PN}-python " |
| 41 | |
| 42 | RDEPENDS:${PN}-python += "python3-core" |
| 43 | FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*" |
| 44 | |
| 45 | do_configure:prepend() { |
| 46 | sh autogen.sh |
| 47 | } |
| 48 | |
| 49 | do_compile:prepend() { |
| 50 | # Make sure the recompile is OK |
| 51 | rm -f ${B}/.depend |
| 52 | } |
| 53 | |
| 54 | FILES:whiptail = "${bindir}/whiptail" |
| 55 | |
| 56 | BBCLASSEXTEND = "native nativesdk" |