Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "A simple wrapper around optparse for powerful command line utilities." |
| 2 | DESCRIPTION = "\ |
| 3 | Click is a Python package for creating beautiful command line interfaces \ |
| 4 | in a composable way with as little code as necessary. It's the "Command \ |
| 5 | Line Interface Creation Kit". It's highly configurable but comes with \ |
| 6 | sensible defaults out of the box." |
| 7 | HOMEPAGE = "http://click.pocoo.org/" |
| 8 | LICENSE = "BSD-3-Clause" |
Andrew Geissler | eafcbb8 | 2020-06-05 17:59:17 -0500 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=1fa98232fd645608937a0fdc82e999b8" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "8c04c11192119b1ef78ea049e0a6f0463e4c48ef00a30160c704337586f3ad7a" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 13 | inherit pypi setuptools3 ptest |
| 14 | |
| 15 | SRC_URI += " \ |
| 16 | file://run-ptest \ |
| 17 | " |
| 18 | |
| 19 | RDEPENDS_${PN}-ptest += " \ |
| 20 | ${PYTHON_PN}-pytest \ |
| 21 | ${PYTHON_PN}-terminal \ |
| 22 | ${PYTHON_PN}-unixadmin \ |
| 23 | " |
| 24 | |
| 25 | do_install_ptest() { |
| 26 | install -d ${D}${PTEST_PATH}/tests |
| 27 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 28 | } |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 29 | |
| 30 | UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/" |
| 31 | |
| 32 | CLEANBROKEN = "1" |
| 33 | |
| 34 | RDEPENDS_${PN} += "\ |
| 35 | ${PYTHON_PN}-io \ |
| 36 | ${PYTHON_PN}-threading \ |
| 37 | " |
| 38 | |
| 39 | BBCLASSEXTEND = "native nativesdk" |