Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "This is the io_uring library, liburing." |
| 2 | DESCRIPTION = "liburing provides helpers to setup and teardown io_uring \ |
| 3 | instances, and also a simplified interface for applications that don't need \ |
| 4 | (or want) to deal with the full kernel side implementation." |
| 5 | HOMEPAGE = "https://github.com/axboe/liburing" |
| 6 | BUGTRACKER = "https://github.com/axboe/liburing/issues" |
| 7 | SECTION = "libs" |
| 8 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 9 | LICENSE = "LGPL-2.1-only | MIT" |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=2b0e9926530c269f5ae95560370195af" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 11 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 12 | SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https \ |
| 13 | file://0001-examples-test-Remove-unused-linux-errqueue.h.patch" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 14 | SRC_URI:append:libc-musl:riscv64 = " file://0001-do-not-build-examples.patch " |
| 15 | SRC_URI:append:libc-musl:riscv32 = " file://0001-do-not-build-examples.patch " |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 16 | SRCREV = "f5cac78e621ab452d3035902085f66d2bf73243b" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 17 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 18 | PV .= "+2.4+git${SRCPV}" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | DEPENDS:append:libc-musl = " libucontext" |
| 22 | XCFLAGS = "-pthread" |
| 23 | XCFLAGS:append:libc-musl = " -lucontext" |
| 24 | |
| 25 | EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'" |
| 26 | do_configure() { |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 27 | ${S}/configure --prefix=${prefix} --libdir=${libdir} --libdevdir=${libdir} --mandir=${mandir} --datadir=${datadir} --includedir=${includedir} |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 28 | } |
| 29 | do_install () { |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 30 | oe_runmake install DESTDIR=${D} |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 31 | } |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 32 | |
| 33 | BBCLASSEXTEND = "native nativesdk" |