blob: 20e77c63dc2fe25d42e55ddd23a1c53e94f50990 [file] [log] [blame]
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05001SUMMARY = "Reboot the device to a specific mode."
2AUTHOR = "Daniele Debernardi <drebrez@gmail.com>"
3
4LICENSE = "GPL-3.0-or-later"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
6
7SRC_URI = "git://gitlab.com/postmarketOS/reboot-mode.git;protocol=http;branch=master"
8SRCREV = "84831b20512abd9033414ca5f5a023f333525335"
9
10S = "${WORKDIR}/git"
11
12do_compile() {
13 ${CC} ${CFLAGS} ${LDFLAGS} reboot-mode.c -o reboot-mode
14}
15
16do_install() {
17 install -D -m 0755 ${S}/reboot-mode ${D}${bindir}/reboot-mode
18}