Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame^] | 1 | SUMMARY = "Reboot the device to a specific mode." |
| 2 | AUTHOR = "Daniele Debernardi <drebrez@gmail.com>" |
| 3 | |
| 4 | LICENSE = "GPL-3.0-or-later" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d" |
| 6 | |
| 7 | SRC_URI = "git://gitlab.com/postmarketOS/reboot-mode.git;protocol=http;branch=master" |
| 8 | SRCREV = "84831b20512abd9033414ca5f5a023f333525335" |
| 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | |
| 12 | do_compile() { |
| 13 | ${CC} ${CFLAGS} ${LDFLAGS} reboot-mode.c -o reboot-mode |
| 14 | } |
| 15 | |
| 16 | do_install() { |
| 17 | install -D -m 0755 ${S}/reboot-mode ${D}${bindir}/reboot-mode |
| 18 | } |