blob: 5b3ea1bb77c9ddc0db150804f38c32a9d493817b [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A fully featured modbus protocol stack in python"
2HOMEPAGE = "https://github.com/riptideio/pymodbus/"
3LICENSE = "BSD-3-Clause"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=430604f78bee72425da231d42eac9cee"
Andrew Geissler517393d2023-01-13 08:55:19 -06005DEPENDS += "python3-six-native"
6
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05007SRC_URI[sha256sum] = "2a0c82651a7eb96c784493b5fc26ccca26ba8e9530258d811dab50b87ce132de"
Andrew Geissler517393d2023-01-13 08:55:19 -06008S = "${WORKDIR}/pymodbus-${PV}"
9
10inherit pypi setuptools3
11
12PACKAGECONFIG ??= ""
13PACKAGECONFIG[repl] = ",,,python3-aiohttp python3-click python3-prompt-toolkit python3-pygments python3-pyserial-asyncio"
14PACKAGECONFIG[asyncio] = ",,,python3-pyserial-asyncio"
15PACKAGECONFIG[tornado] = ",,,python3-tornado"
16PACKAGECONFIG[twisted] = ",,,python3-twisted-conch"
17PACKAGECONFIG[redis] = ",,,python3-redis"
18PACKAGECONFIG[sql] = ",,,python3-sqlalchemy"
19
20RDEPENDS:${PN} += " \
21 python3-asyncio \
22 python3-core \
23 python3-io \
24 python3-json \
25 python3-logging \
26 python3-math \
27 python3-netserver \
28"
29
30RDEPENDS:${PN} += " \
31 python3-pyserial \
32 python3-six \
33"
34
35