Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame^] | 1 | DESCRIPTION = "The tools for verifying whether a certificate is valid for the intended purposes." |
| 2 | HOMEPAGE = "https://pypi.org/project/service-identity" |
| 3 | AUTHOR = "Hynek Schlawack" |
| 4 | |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8a0f079f4e6a215d6bd6f9d97cab4d5f" |
| 7 | |
| 8 | SRC_URI[md5sum] = "5e5c195d8fcedc72f9068be2ad9b5a13" |
| 9 | SRC_URI[sha256sum] = "6e6c6086ca271dc11b033d17c3a8bea9f24ebff920c587da090afc9519419d34" |
| 10 | |
| 11 | inherit pypi setuptools3 ptest |
| 12 | |
| 13 | SRC_URI += " \ |
| 14 | file://run-ptest \ |
| 15 | " |
| 16 | |
| 17 | RDEPENDS:${PN}-ptest += " \ |
| 18 | ${PYTHON_PN}-pytest \ |
| 19 | " |
| 20 | |
| 21 | do_install_ptest() { |
| 22 | install -d ${D}${PTEST_PATH}/tests |
| 23 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 24 | cp -rf ${S}/setup.py ${D}${PTEST_PATH} |
| 25 | } |