blob: 0210a5de2278fa3977724afd353df771db19b8c5 [file] [log] [blame]
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05001DESCRIPTION = "The tools for verifying whether a certificate is valid for the intended purposes."
2HOMEPAGE = "https://pypi.org/project/service-identity"
3AUTHOR = "Hynek Schlawack"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=8a0f079f4e6a215d6bd6f9d97cab4d5f"
7
8SRC_URI[md5sum] = "5e5c195d8fcedc72f9068be2ad9b5a13"
9SRC_URI[sha256sum] = "6e6c6086ca271dc11b033d17c3a8bea9f24ebff920c587da090afc9519419d34"
10
11inherit pypi setuptools3 ptest
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS:${PN}-ptest += " \
18 ${PYTHON_PN}-pytest \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24 cp -rf ${S}/setup.py ${D}${PTEST_PATH}
25}