Andrew Geissler | d25ed32 | 2020-06-27 00:28:28 -0500 | [diff] [blame] | 1 | SUMMARY = "A multi-platform support library with a focus on asynchronous I/O" |
| 2 | HOMEPAGE = "https://github.com/libuv/libuv" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 3 | DESCRIPTION = "libuv is a multi-platform support library with a focus on asynchronous I/O. It was primarily developed for use by Node.js, but it's also used by Luvit, Julia, pyuv, and others." |
Andrew Geissler | d25ed32 | 2020-06-27 00:28:28 -0500 | [diff] [blame] | 4 | BUGTRACKER = "https://github.com/libuv/libuv/issues" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a68902a430e32200263d182d44924d47" |
| 7 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 8 | SRCREV = "6ce14710da7079eb248868171f6343bc409ea3a4" |
Andrew Geissler | d25ed32 | 2020-06-27 00:28:28 -0500 | [diff] [blame] | 9 | SRC_URI = "git://github.com/libuv/libuv;branch=v1.x" |
| 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | inherit autotools |
| 14 | |
| 15 | do_configure() { |
| 16 | ${S}/autogen.sh || bbnote "${PN} failed to autogen.sh" |
| 17 | oe_runconf |
| 18 | } |
| 19 | |
| 20 | BBCLASSEXTEND = "native" |