Vijay Khemka | 45269ba | 2018-12-13 11:07:06 -0800 | [diff] [blame] | 1 | FILESEXTRAPATHS_append := "${THISDIR}/files:" |
| 2 | |
Vijay Khemka | 3becf04 | 2019-01-08 10:45:20 -0800 | [diff] [blame] | 3 | inherit obmc-phosphor-systemd |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a8328fd2a610bf4527feedcaa3ae3d14" |
Vijay Khemka | 45269ba | 2018-12-13 11:07:06 -0800 | [diff] [blame] | 6 | |
| 7 | S = "${WORKDIR}/" |
| 8 | |
| 9 | SRC_URI = "file://setup_gpio.sh \ |
| 10 | file://power-util \ |
| 11 | file://host-gpio.service \ |
| 12 | file://host-poweroff.service \ |
Vijay Khemka | 3becf04 | 2019-01-08 10:45:20 -0800 | [diff] [blame] | 13 | file://host-poweron.service \ |
| 14 | file://LICENSE" |
Vijay Khemka | 45269ba | 2018-12-13 11:07:06 -0800 | [diff] [blame] | 15 | |
| 16 | DEPENDS = "systemd" |
| 17 | RDEPENDS_${PN} = "bash" |
| 18 | |
| 19 | SYSTEMD_PACKAGES = "${PN}" |
| 20 | SYSTEMD_SERVICE_${PN} = "host-gpio.service host-poweron.service host-poweroff.service" |
| 21 | |
| 22 | do_install() { |
| 23 | install -d ${D}/usr/sbin |
| 24 | install -m 0755 ${S}setup_gpio.sh ${D}/${sbindir}/ |
| 25 | install -m 0755 ${S}power-util ${D}/${sbindir}/ |
| 26 | } |