Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | python __anonymous() { |
| 2 | if "linux-raspberrypi-dev" not in d.getVar("PREFERRED_PROVIDER_virtual/kernel"): |
| 3 | msg = "Skipping linux-raspberrypi-dev as it is not the preferred " + \ |
| 4 | "provider of virtual/kernel." |
| 5 | raise bb.parse.SkipRecipe(msg) |
| 6 | } |
| 7 | |
| 8 | FILESEXTRAPATHS_prepend := "${THISDIR}/linux-raspberrypi:" |
| 9 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | LINUX_VERSION ?= "4.19" |
| 11 | LINUX_RPI_BRANCH ?= "rpi-4.19.y" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 12 | |
| 13 | SRCREV = "${AUTOREV}" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 14 | SRC_URI = " \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 15 | git://github.com/raspberrypi/linux.git;protocol=git;branch=${LINUX_RPI_BRANCH} \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 16 | " |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 17 | require linux-raspberrypi.inc |
| 18 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 19 | # Disable version check so that we don't have to edit this recipe every time |
| 20 | # upstream bumps the version |
| 21 | KERNEL_VERSION_SANITY_SKIP = "1" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | |
| 23 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" |