Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | SUMMARY = "Linux security scanner" |
| 2 | DESCRIPTION = "Buck-Security is a security scanner for Debian and Ubuntu Linux. It runs a couple of important checks and helps you to harden your Linux \ |
| 3 | system. This enables you to quickly overview the security status of your Linux system." |
| 4 | SECTION = "security" |
| 5 | LICENSE = "GPL-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" |
| 7 | RDEPENDS_${PN} = "coreutils \ |
| 8 | gnupg \ |
| 9 | net-tools \ |
| 10 | perl \ |
| 11 | perl-module-data-dumper \ |
| 12 | perl-module-file-basename \ |
| 13 | perl-module-file-spec \ |
| 14 | perl-module-getopt-long \ |
| 15 | perl-module-lib \ |
| 16 | perl-module-posix \ |
| 17 | perl-module-term-ansicolor \ |
| 18 | perl-module-time-localtime \ |
| 19 | pinentry \ |
| 20 | " |
| 21 | |
| 22 | RDEPENDS_${PN}_class-native = "coreutils \ |
| 23 | net-tools \ |
| 24 | perl \ |
| 25 | perl-module-data-dumper \ |
| 26 | perl-module-file-basename \ |
| 27 | perl-module-file-spec \ |
| 28 | perl-module-getopt-long \ |
| 29 | perl-module-lib \ |
| 30 | perl-module-posix \ |
| 31 | perl-module-term-ansicolor \ |
| 32 | perl-module-time-localtime \ |
| 33 | " |
| 34 | |
| 35 | SRC_URI = "http://sourceforge.net/projects/buck-security/files/buck-security/buck-security_${PV}/${BPN}_${PV}.tar.gz" |
| 36 | |
| 37 | SRC_URI[md5sum] = "611a3e9bb7ed8a8270aa15216c321c53" |
| 38 | SRC_URI[sha256sum] = "c533c6631ec3554dd8d39d2d1c3ed44badbbf50810ebb75469c74639fa294b01" |
| 39 | |
| 40 | S = "${WORKDIR}/${BPN}_${PV}" |
| 41 | |
| 42 | do_configure() { |
| 43 | : |
| 44 | } |
| 45 | |
| 46 | do_compile() { |
| 47 | : |
| 48 | } |
| 49 | |
| 50 | do_install() { |
| 51 | install -d ${D}${bindir}/buck |
| 52 | cp -r ${S}/* ${D}${bindir}/buck |
| 53 | cp -r ${S}/buck-security ${D}${bindir} |
| 54 | sed -i 's!use lib "checks"!use lib File::Spec->catfile(dirname(File::Spec->rel2abs(__FILE__)), "buck/checks")!' ${D}${bindir}/buck-security |
| 55 | sed -i 's!use lib "checks/lib"!use lib File::Spec->catfile(dirname(File::Spec->rel2abs(__FILE__)), "buck/checks/lib")!' ${D}${bindir}/buck-security |
| 56 | sed -i 's!use lib "lib"!use lib File::Spec->catfile(dirname(File::Spec->rel2abs(__FILE__)), "buck/lib")!' ${D}${bindir}/buck-security |
| 57 | sed -i 's!my $buck_root = "."!my $buck_root = File::Spec->catfile(dirname(File::Spec->rel2abs(__FILE__)), "buck")!' ${D}${bindir}/buck-security |
| 58 | |
| 59 | } |
| 60 | |
| 61 | FILES_${PN} = "${bindir}/*" |
| 62 | |
| 63 | BBCLASSEXTEND = "native" |