Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 1 | inherit goarch |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 2 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 3 | GO_PARALLEL_BUILD ?= "${@oe.utils.parallel_make_argument(d, '-p %d')}" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 4 | |
| 5 | GOROOT_class-native = "${STAGING_LIBDIR_NATIVE}/go" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 6 | GOROOT_class-nativesdk = "${STAGING_DIR_TARGET}${libdir}/go" |
| 7 | GOROOT = "${STAGING_LIBDIR}/go" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 8 | export GOROOT |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 9 | export GOROOT_FINAL = "${libdir}/go" |
Brad Bishop | c8f4712 | 2019-06-24 09:36:18 -0400 | [diff] [blame] | 10 | export GOCACHE = "${B}/.cache" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 11 | |
Brad Bishop | d89cb5f | 2019-04-10 09:02:41 -0400 | [diff] [blame] | 12 | export GOARCH = "${TARGET_GOARCH}" |
| 13 | export GOOS = "${TARGET_GOOS}" |
| 14 | export GOHOSTARCH="${BUILD_GOARCH}" |
| 15 | export GOHOSTOS="${BUILD_GOOS}" |
| 16 | |
| 17 | GOARM[export] = "0" |
| 18 | GOARM_arm_class-target = "${TARGET_GOARM}" |
| 19 | GOARM_arm_class-target[export] = "1" |
| 20 | |
| 21 | GO386[export] = "0" |
| 22 | GO386_x86_class-target = "${TARGET_GO386}" |
| 23 | GO386_x86_class-target[export] = "1" |
Brad Bishop | d89cb5f | 2019-04-10 09:02:41 -0400 | [diff] [blame] | 24 | |
| 25 | GOMIPS[export] = "0" |
| 26 | GOMIPS_mips_class-target = "${TARGET_GOMIPS}" |
| 27 | GOMIPS_mips_class-target[export] = "1" |
| 28 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | DEPENDS_GOLANG_class-target = "virtual/${TUNE_PKGARCH}-go virtual/${TARGET_PREFIX}go-runtime" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 30 | DEPENDS_GOLANG_class-native = "go-native" |
| 31 | DEPENDS_GOLANG_class-nativesdk = "virtual/${TARGET_PREFIX}go-crosssdk virtual/${TARGET_PREFIX}go-runtime" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 32 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 33 | DEPENDS_append = " ${DEPENDS_GOLANG}" |
| 34 | |
| 35 | GO_LINKSHARED ?= "${@'-linkshared' if d.getVar('GO_DYNLINK') else ''}" |
| 36 | GO_RPATH_LINK = "${@'-Wl,-rpath-link=${STAGING_DIR_TARGET}${libdir}/go/pkg/${TARGET_GOTUPLE}_dynlink' if d.getVar('GO_DYNLINK') else ''}" |
| 37 | GO_RPATH = "${@'-r ${libdir}/go/pkg/${TARGET_GOTUPLE}_dynlink' if d.getVar('GO_DYNLINK') else ''}" |
| 38 | GO_RPATH_class-native = "${@'-r ${STAGING_LIBDIR_NATIVE}/go/pkg/${TARGET_GOTUPLE}_dynlink' if d.getVar('GO_DYNLINK') else ''}" |
| 39 | GO_RPATH_LINK_class-native = "${@'-Wl,-rpath-link=${STAGING_LIBDIR_NATIVE}/go/pkg/${TARGET_GOTUPLE}_dynlink' if d.getVar('GO_DYNLINK') else ''}" |
| 40 | GO_EXTLDFLAGS ?= "${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS} ${GO_RPATH_LINK} ${LDFLAGS}" |
| 41 | GO_LINKMODE ?= "" |
| 42 | GO_LINKMODE_class-nativesdk = "--linkmode=external" |
| 43 | GO_LDFLAGS ?= '-ldflags="${GO_RPATH} ${GO_LINKMODE} -extldflags '${GO_EXTLDFLAGS}'"' |
| 44 | export GOBUILDFLAGS ?= "-v ${GO_LDFLAGS}" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 45 | export GOPATH_OMIT_IN_ACTIONID ?= "1" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 46 | export GOPTESTBUILDFLAGS ?= "${GOBUILDFLAGS} -c" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 47 | export GOPTESTFLAGS ?= "" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 48 | GOBUILDFLAGS_prepend_task-compile = "${GO_PARALLEL_BUILD} " |
| 49 | |
| 50 | export GO = "${HOST_PREFIX}go" |
| 51 | GOTOOLDIR = "${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go/pkg/tool/${BUILD_GOTUPLE}" |
| 52 | GOTOOLDIR_class-native = "${STAGING_LIBDIR_NATIVE}/go/pkg/tool/${BUILD_GOTUPLE}" |
| 53 | export GOTOOLDIR |
| 54 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 55 | export CGO_ENABLED ?= "1" |
| 56 | export CGO_CFLAGS ?= "${CFLAGS}" |
| 57 | export CGO_CPPFLAGS ?= "${CPPFLAGS}" |
| 58 | export CGO_CXXFLAGS ?= "${CXXFLAGS}" |
| 59 | export CGO_LDFLAGS ?= "${LDFLAGS}" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 60 | |
| 61 | GO_INSTALL ?= "${GO_IMPORT}/..." |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 62 | GO_INSTALL_FILTEROUT ?= "${GO_IMPORT}/vendor/" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 63 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 64 | B = "${WORKDIR}/build" |
| 65 | export GOPATH = "${B}" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 66 | export GOTMPDIR ?= "${WORKDIR}/go-tmp" |
| 67 | GOTMPDIR[vardepvalue] = "" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 68 | |
| 69 | python go_do_unpack() { |
| 70 | src_uri = (d.getVar('SRC_URI') or "").split() |
| 71 | if len(src_uri) == 0: |
| 72 | return |
| 73 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 74 | fetcher = bb.fetch2.Fetch(src_uri, d) |
| 75 | for url in fetcher.urls: |
| 76 | if fetcher.ud[url].type == 'git': |
| 77 | if fetcher.ud[url].parm.get('destsuffix') is None: |
| 78 | s_dirname = os.path.basename(d.getVar('S')) |
| 79 | fetcher.ud[url].parm['destsuffix'] = os.path.join(s_dirname, 'src', d.getVar('GO_IMPORT')) + '/' |
| 80 | fetcher.unpack(d.getVar('WORKDIR')) |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 81 | } |
| 82 | |
| 83 | go_list_packages() { |
| 84 | ${GO} list -f '{{.ImportPath}}' ${GOBUILDFLAGS} ${GO_INSTALL} | \ |
| 85 | egrep -v '${GO_INSTALL_FILTEROUT}' |
| 86 | } |
| 87 | |
| 88 | go_list_package_tests() { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 89 | ${GO} list -f '{{.ImportPath}} {{.TestGoFiles}}' ${GOBUILDFLAGS} ${GO_INSTALL} | \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 90 | grep -v '\[\]$' | \ |
| 91 | egrep -v '${GO_INSTALL_FILTEROUT}' | \ |
| 92 | awk '{ print $1 }' |
| 93 | } |
| 94 | |
| 95 | go_do_configure() { |
| 96 | ln -snf ${S}/src ${B}/ |
| 97 | } |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 98 | do_configure[dirs] =+ "${GOTMPDIR}" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 99 | |
| 100 | go_do_compile() { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 101 | export TMPDIR="${GOTMPDIR}" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 102 | if [ -n "${GO_INSTALL}" ]; then |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 103 | if [ -n "${GO_LINKSHARED}" ]; then |
| 104 | ${GO} install ${GOBUILDFLAGS} `go_list_packages` |
| 105 | rm -rf ${B}/bin |
| 106 | fi |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 107 | ${GO} install ${GO_LINKSHARED} ${GOBUILDFLAGS} `go_list_packages` |
| 108 | fi |
| 109 | } |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 110 | do_compile[dirs] =+ "${GOTMPDIR}" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 111 | do_compile[cleandirs] = "${B}/bin ${B}/pkg" |
| 112 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 113 | go_do_install() { |
| 114 | install -d ${D}${libdir}/go/src/${GO_IMPORT} |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 115 | tar -C ${S}/src/${GO_IMPORT} -cf - --exclude-vcs --exclude '*.test' --exclude 'testdata' . | \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 116 | tar -C ${D}${libdir}/go/src/${GO_IMPORT} --no-same-owner -xf - |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 117 | tar -C ${B} -cf - --exclude-vcs pkg | tar -C ${D}${libdir}/go --no-same-owner -xf - |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 118 | |
| 119 | if [ -n "`ls ${B}/${GO_BUILD_BINDIR}/`" ]; then |
| 120 | install -d ${D}${bindir} |
| 121 | install -m 0755 ${B}/${GO_BUILD_BINDIR}/* ${D}${bindir}/ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 122 | fi |
| 123 | } |
| 124 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 125 | go_stage_testdata() { |
| 126 | oldwd="$PWD" |
| 127 | cd ${S}/src |
| 128 | find ${GO_IMPORT} -depth -type d -name testdata | while read d; do |
| 129 | if echo "$d" | grep -q '/vendor/'; then |
| 130 | continue |
| 131 | fi |
| 132 | parent=`dirname $d` |
| 133 | install -d ${D}${PTEST_PATH}/$parent |
| 134 | cp --preserve=mode,timestamps -R $d ${D}${PTEST_PATH}/$parent/ |
| 135 | done |
| 136 | cd "$oldwd" |
| 137 | } |
| 138 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 139 | EXPORT_FUNCTIONS do_unpack do_configure do_compile do_install |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 140 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 141 | FILES_${PN}-dev = "${libdir}/go/src" |
| 142 | FILES_${PN}-staticdev = "${libdir}/go/pkg" |
| 143 | |
| 144 | INSANE_SKIP_${PN} += "ldflags" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 145 | |
| 146 | # Add -buildmode=pie to GOBUILDFLAGS to satisfy "textrel" QA checking, but mips |
| 147 | # doesn't support -buildmode=pie, so skip the QA checking for mips and its |
| 148 | # variants. |
| 149 | python() { |
| 150 | if 'mips' in d.getVar('TARGET_ARCH'): |
| 151 | d.appendVar('INSANE_SKIP_%s' % d.getVar('PN'), " textrel") |
| 152 | else: |
| 153 | d.appendVar('GOBUILDFLAGS', ' -buildmode=pie') |
| 154 | } |