Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Disk partition editing/resizing utility" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/parted/parted.html" |
| 3 | LICENSE = "GPLv3+" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=2f31b266d3440dd7ee50f92cf67d8e6c" |
| 5 | SECTION = "console/tools" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 6 | DEPENDS = "ncurses readline util-linux virtual/libiconv" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 7 | PR = "r1" |
| 8 | |
| 9 | SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \ |
| 10 | file://no_check.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 11 | file://fix-doc-mandir.patch \ |
| 12 | file://fix-compile-failure-while-dis.patch \ |
| 13 | file://0001-Include-fcntl.h-in-platform_defs.h.patch \ |
| 14 | file://0001-Unset-need_charset_alias-when-building-for-musl.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 15 | file://0002-libparted_fs_resize-link-against-libuuid-explicitly-.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 16 | file://0001-Move-python-helper-scripts-used-only-in-tests-to-Pyt.patch \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 17 | file://0001-linux-Include-sys-sysmacros.h-for-major-macro.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | file://run-ptest \ |
| 19 | file://Makefile \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 20 | file://0001-libparted-Use-read-only-when-probing-devices-on-linu.patch \ |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 21 | file://dm_check.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 22 | " |
| 23 | |
| 24 | SRC_URI[md5sum] = "0247b6a7b314f8edeb618159fa95f9cb" |
| 25 | SRC_URI[sha256sum] = "858b589c22297cacdf437f3baff6f04b333087521ab274f7ab677cb8c6bb78e4" |
| 26 | |
| 27 | EXTRA_OECONF = "--disable-device-mapper" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 28 | |
| 29 | inherit autotools pkgconfig gettext texinfo ptest |
| 30 | |
| 31 | BBCLASSEXTEND = "native" |
| 32 | |
| 33 | do_compile_ptest() { |
| 34 | oe_runmake -C tests print-align print-max dup-clobber duplicate fs-resize |
| 35 | } |
| 36 | |
| 37 | do_install_ptest() { |
| 38 | t=${D}${PTEST_PATH} |
| 39 | mkdir $t/build-aux |
| 40 | cp ${S}/build-aux/test-driver $t/build-aux/ |
| 41 | cp -r ${S}/tests $t |
| 42 | cp ${WORKDIR}/Makefile $t/tests/ |
| 43 | sed -i "s|^VERSION.*|VERSION = ${PV}|g" $t/tests/Makefile |
| 44 | for i in print-align print-max dup-clobber duplicate fs-resize; \ |
| 45 | do cp ${B}/tests/.libs/$i $t/tests/; \ |
| 46 | done |
| 47 | sed -e 's| ../parted||' -i $t/tests/*.sh |
| 48 | } |
| 49 | |
Brad Bishop | 393846f | 2019-05-20 12:24:11 -0400 | [diff] [blame] | 50 | RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3 make" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 51 | |
| 52 | inherit update-alternatives |
| 53 | |
| 54 | ALTERNATIVE_PRIORITY = "100" |
| 55 | ALTERNATIVE_${PN} = "partprobe" |
| 56 | ALTERNATIVE_LINK_NAME[partprobe] = "${sbindir}/partprobe" |